TX2 target installation stopped in "Determining the IP address of target".

With several attempts to install the JetPack into target, it always stopped at “Finished Flashing OS. Determining the IP address of target…”.
At that time, the LED of TX2 ethernet were both dark.

What I had tried:

  1. Press the Reset key in TX2. No response at all.
  2. Plug in and out the power supply to make it on again.
  3. Retry installation more than 2 times.

Before installation, the TX2 works properly with out-of-box system. Such as “git clone…” and “TensorFlow installation” and so on.
It shows the cable and device of display and ethernet are working properly.

I got the right procedure from Jetson video for installation JetPack 3.0.
It seems the ethernet of TX2 not working with my installation at that time.

Would you please anyone could help me out? Thanks.

Consider that JetPack can do package updates separately from flash…they just happen to be bundled to do both. You can flash, and then reboot and restart JetPack without the flash step checked in order to deal with packages.

When doing flash the USB cable is the means of communications. When doing package updates you must use the wired ethernet. If you are using WiFi at the Jetson end this would cause failure.

Is your Jetson connected via wired ethernet to the host PC, or is it instead connected to a router? One of those must provide a router function in order for the Jetson to get an IP address. The logs of the router (or the PC if acting as router) would provide the address.

It is common that video can fail and make it look like the Jetson did not boot even though it really is running. Probably the best tool is a serial console cable since you will see everything from U-Boot on (even if there is a fairly catastrophic video and network failure). If you can use a serial console this is recommended. See:
http://www.jetsonhacks.com/2017/03/24/serial-console-nvidia-jetson-tx2/

My Jetson connected via wired Ethernet to the router. The host PC is also connected to the same router with wired Ethernet. The router provide DHCP service well.

After set up serial console, just as your said, it was display error. It works well after change to a HDMI directly display. Thanks for prompt support. The serial 2 console guide was also desired. Thumbs up!

The following worked for me:

  1. If the process is stuck at “Determining target IP address” (without throwing a timeout error), try pinging to the target’s (Jetson TX2) IP address separately. If the pinging works, then proceed to step 2 and step 3. If the pinging does not work, look into step 4.
  2. While running the jetson tx2 run script make sure that the host Ethernet interface is correctly selected.
  3. Once flashing is complete and it starts to determine the IP address, disconnect the USB from the jetson tx2. This is where my code started working and the host was able to decide the target IP address. It completed all the necessary installations and I was able to run a sample backend example.
  4. When pinging does not work, make sure internet is correctly connected to the Jetson TX2 from the same switch and make sure the IP address (minus the subnet) matches the host.

Hope this helps someone with similar Jetson TX2 issues!

Cheers!
T

Hi ta2184,

Thanks for the feedback.