TX2 Turn-off Shortly After Booting


I have encountered a problem with TX2, Two of my TX2s are having this same problem:

I flashed the OS with Jetpack3.1. After putting the TX2 on the development board, and connecting the power cable, the red LED indicator turned on. And after pressing the power-on button, two green LEDs turned on and the fan started running.
But after several seconds of booting up, it turned off itself and only leave the red LED on (Green LEDs off and fan off. No printouts on my monitor). Looks like it shut down the bootup process itself.
I tried bootup several times, it turned itself off everytime.

Have you meet similar problem before? Do you think its hardware or software problem?


Fan doesn’t start running, by default, as far as I know.
Did you try JetPack 3.2?

I have setup over 30 TX2s for my team using Jetpack3.1. only these two have the issue. I think the problem is not the fan but the two green LEDs on board turns off and only leaving the red LED (power indicator).


Still the same if you keep power button pressed for 5 seconds ?
I have a TX1 dev board that sometimes misses power on, but pressing button for 5 seconds it finally starts.

Serial console would probably get insights about the problem. May you post these logs ?

Hi chenxuan,

Did you do cross checking with other module/carrier board?
What’s the value of current of these two sets? If the current is much high, then perhaps some components are broken.
And any log will be helpful.

@Trumany: I did cross checking with different TX2s and the other TX2 development board. So did my colleague. I tried to use serial cables (connected to pin 8, 9, 10 on the J21 pins) to get printouts on serial terminal, but only printing garbage and the TX2 shutoff shortly after.

What’s the input current value? Is it possible to be in recovery mode? This seems like a hardware issue, might need RMA if no other findings.

@chenxuan, have you found the solution for this. I got a same issue :(