tx2 usb controller issue

Hi NV people

Did tx2 have passed the USB-IF certification or not?

how do i get this certification ?

Hi etta,

We have guidance for passing compliance test, please refer to:
http://developer.nvidia.com/embedded/dlc/tx2-series-interface-tuning-compliance-testing-guide

Thanks

Hi Kaycc

our customer use intel realsense camera on tx2.

when we do the long time test ,the realsense camera have usb error on nvidia EVB and our carried board.

Jan 15 11:54:27 tegra-ubuntu kernel: [ 3198.131974] usb 2-1.1: Disable of device-initiated U1 failed.
Jan 15 11:54:27 tegra-ubuntu kernel: [ 3198.139931] usb 2-1.1: Disable of device-initiated U2 failed.
Jan 15 11:54:28 tegra-ubuntu kernel: [ 3198.464499] usb 2-1.1: Device not responding to setup address.
Jan 15 11:54:28 tegra-ubuntu kernel: [ 3198.672225] usb 2-1.1: Device not responding to setup address.
Jan 15 11:54:28 tegra-ubuntu kernel: [ 3198.867289] xhci-tegra 3530000.xhci: ERROR: unexpected command completion code 0x13.
Jan 15 11:54:28 tegra-ubuntu kernel: [ 3198.875129] usb 2-1.1: Not enough bandwidth for altsetting 0
Jan 15 11:54:28 tegra-ubuntu kernel: [ 3198.882789] usb 2-1.1: device not accepting address 4, error -71
Jan 15 11:54:28 tegra-ubuntu kernel: [ 3198.888869] xhci-tegra 3530000.xhci: ERROR: unexpected command completion code 0x13.
Jan 15 11:54:28 tegra-ubuntu kernel: [ 3198.888891] usb 2-1.1: Not enough bandwidth for altsetting 0
Jan 15 11:54:29 tegra-ubuntu kernel: [ 3199.620457] usb 2-1.1: Device not responding to setup address.
Jan 15 11:54:29 tegra-ubuntu kernel: [ 3199.828343] usb 2-1.1: Device not responding to setup address.
Jan 15 11:54:29 tegra-ubuntu kernel: [ 3200.034803] usb 2-1.1: device not accepting address 4, error -71
Jan 15 11:54:29 tegra-ubuntu kernel: [ 3200.110106] xhci-tegra 3530000.xhci: tegra_xhci_mbox_work mailbox command 6
Jan 15 11:54:30 tegra-ubuntu kernel: [ 3200.760516] usb 2-1.1: Device not responding to setup address.
Jan 15 11:54:30 tegra-ubuntu kernel: [ 3200.968421] usb 2-1.1: Device not responding to setup address.
Jan 15 11:54:30 tegra-ubuntu kernel: [ 3201.174820] usb 2-1.1: device not accepting address 4, error -71
Jan 15 11:54:31 tegra-ubuntu kernel: [ 3201.900659] usb 2-1.1: Device not responding to setup address.
Jan 15 11:54:31 tegra-ubuntu kernel: [ 3202.108363] usb 2-1.1: Device not responding to setup address.
Jan 15 11:54:32 tegra-ubuntu kernel: [ 3202.314834] usb 2-1.1: device not accepting address 4, error -71
Jan 15 11:54:32 tegra-ubuntu kernel: [ 3202.325150] uvcvideo: Unknown video format 00000050-0000-0010-8000-00aa00389b71
Jan 15 11:54:32 tegra-ubuntu kernel: [ 3202.333139] uvcvideo: Unknown video format 00000032-0000-0010-8000-00aa00389b71
Jan 15 11:54:32 tegra-ubuntu kernel: [ 3202.340781] uvcvideo: Found UVC 1.50 device Intel(R) RealSense(TM) Depth Camera 435  (8086:0b07)
Jan 15 11:54:32 tegra-ubuntu kernel: [ 3202.351662] xhci-tegra 3530000.xhci: ERROR: unexpected command completion code 0x13.
Jan 15 11:54:32 tegra-ubuntu kernel: [ 3202.359590] usb 2-1.1: Not enough bandwidth for altsetting 0

Rev.30
Jan 17 22:42:22 tegra-ubuntu kernel: [ 1400.789734] xhci-tegra 3530000.xhci: tegra_xhci_mbox_work mailbox command 6
Jan 17 22:42:22 tegra-ubuntu kernel: [ 1400.949919] xhci-tegra 3530000.xhci: tegra_xhci_mbox_work mailbox command 6
Jan 17 22:42:23 tegra-ubuntu kernel: [ 1402.266847] xhci-tegra 3530000.xhci: tegra_xhci_mbox_work mailbox command 6
Jan 17 22:42:23 tegra-ubuntu kernel: [ 1402.412520] xhci-tegra 3530000.xhci: tegra_xhci_mbox_work mailbox command 6
Jan 17 22:42:25 tegra-ubuntu kernel: [ 1403.728684] xhci-tegra 3530000.xhci: tegra_xhci_mbox_work mailbox command 6
Jan 17 22:42:25 tegra-ubuntu kernel: [ 1404.477800] usb 2-1.4: Disable of device-initiated U1 failed.
Jan 17 22:42:25 tegra-ubuntu kernel: [ 1404.485396] usb 2-1.4: Disable of device-initiated U2 failed.
Jan 17 22:42:26 tegra-ubuntu kernel: [ 1404.799839] usb 2-1.4: Device not responding to setup address.
Jan 17 22:42:26 tegra-ubuntu kernel: [ 1405.006578] usb 2-1.4: reset SuperSpeed USB device number 3 using xhci-tegra
Jan 17 22:42:26 tegra-ubuntu kernel: [ 1405.030172] usb 2-1.4: device descriptor read/8, error -71
Jan 17 22:42:26 tegra-ubuntu kernel: [ 1405.138024] usb 2-1.4: reset SuperSpeed USB device number 3 using xhci-tegra
Jan 17 22:42:26 tegra-ubuntu kernel: [ 1405.162131] usb 2-1.4: device descriptor read/8, error -71
Jan 17 22:42:27 tegra-ubuntu kernel: [ 1405.987796] usb 2-1.4: Device not responding to setup address.
Jan 17 22:42:27 tegra-ubuntu kernel: [ 1406.194594] usb 2-1.4: reset SuperSpeed USB device number 3 using xhci-tegra
Jan 17 22:42:27 tegra-ubuntu kernel: [ 1406.218310] usb 2-1.4: device descriptor read/8, error -71
Jan 17 22:42:27 tegra-ubuntu kernel: [ 1406.326015] usb 2-1.4: reset SuperSpeed USB device number 3 using xhci-tegra
Jan 17 22:42:27 tegra-ubuntu kernel: [ 1406.350348] usb 2-1.4: device descriptor read/8, error -71
Jan 17 22:42:27 tegra-ubuntu kernel: [ 1406.445399] xhci-tegra 3530000.xhci: tegra_xhci_mbox_work mailbox command 6
Jan 17 22:42:28 tegra-ubuntu kernel: [ 1407.175749] usb 2-1.4: Device not responding to setup address.
Jan 17 22:42:28 tegra-ubuntu kernel: [ 1407.382432] usb 2-1.4: reset SuperSpeed USB device number 3 using xhci-tegra
Jan 17 22:42:28 tegra-ubuntu kernel: [ 1407.406093] usb 2-1.4: device descriptor read/8, error -71

customer need to pass USB-IF certification and fixed this issue.

do you have any suggestion for this issue?

Hi,
Have you tried the document at #2 to tune the signals?