TX2 will restart automatically or HDMI cannot wake up after running for a few days

TX2 will restart automatically or HDMI cannot wake up after running for a few days 。
This is the system log of my last restart。
syslog.txt (816.8 KB)

Hi,

Please dump the log from uart when the error happens. When system dies, syslog may not record it.

Also, please learn to check the log by yourself or at least provide the exact timestamp for other people to check.

Incidentally, this is the information for using serial console (and serial console applications can log everything):
http://www.jetsonhacks.com/2017/03/24/serial-console-nvidia-jetson-tx2/

Hi Wayne WWW,

The time when the restart occurred was 28.04.12.

The equipment is now on site, and it does not mean that it will restart at a fixed time in one or two days. When we tested in the laboratory, this did not happen.

Sometimes it is restarting, sometimes the HDMI does not display, and we set the endless screen, the mouse and keyboard cannot wake up. Remote SSH login, “lsusb” can normally recognize USB peripherals such as mouse and keyboard.

From the log, a large number of desktop-related errors were reported before the restart.

Hi,

From the log, a large number of desktop-related errors were reported before the restart.

That log does not help. There are 3 mins gap between the desktop-nm and reboot. I don’t think it is the cause.
Actually, your syslog is full of the nm-applet log and it has been printed for 4 hours before the reboot.

Jul 28 04:09:23 nvidia-desktop nm-applet[7151]: Can't set a parent on widget which has a parent
\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00Jul 28 04:12:37 nvidia-desktop systemd-modules-load[2209]: Inserted module 'bluedroid_pm'
Jul 28 04:12:37 nvidia-desktop systemd-modules-load[2209]: Module 'nvhost_vi' is builtin
Jul 28 04:12:37 nvidia-desktop systemd-modules-load[2209]: Inserted module 'nvgpu'

I don’t think this description really helps. We need the log to tell what issue happens but not just descriptions.
No need to mention you didn’t tell us what is your carrier board or release version.

Please do dump the log from serial console when error happens and attach it here. If you cannot reproduce it now, then you should firstly reproduce it and then come to forum for help.

Also, you should tell other people what is running on the board. If you provide more info, it has more chance to resolve your problem.