TX2 with capture camera picture issue

I have a TX2 box for cammer capture project. I am troubled in some issues. Could you help?
I used the same code and run it in windows and vmware virtual environment. It could run correctly without any issue.
However, when I re-build and setup in TX2, it failed.
It was used to capture picture from the cammer with GVCP control protocol. And The data was sent through UDP.
One pic is 2469888 bytes.
However, it failed every time when it tried to get 200 pictures. The other 199 pictures was good.
I tried to set the jumboframe to large size, it failed also.
I tried to enlarge the receive buffer, it failed also.
And it got the error picture when tried to get 200nd picture.
I am troubling in this issue for a week, could you give me some suggestions?

And the SDK was the opensource.

Don’t have experience for this github. Suggest consult the the github author if able get some debug comment.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.