TX2 won't power on, go into recovery or show up with lsusb

I was asked to post here by online chat support.
My Jetson TX2 was working fine the last time I used it a few months ago.
It’s been sitting on my desk with the red power LED going without being turned on.
I tried to turn it on today and nada.
It won’t go into recovery mode.
The lsusb command doesn’t show anything. I’ve tried with multiple cables on multiple hosts.
I’m guessing it’s dead which is why I followed the RMA guide at https://developer.nvidia.com/embedded/faq so I’m hoping I won’t be going around in circles for too long.
If anyone has any ideas I’d love to hear them because I’m guessing the return process is going to be painful since I’m in Australia but I bought it from an American website.

Hi, it looks like something broken since nothing printed out.

Did you try unplug power and plug in after a while? What’s the input current? High current means some components shorted to ground.

Is there any current value change when press power button?

Hi Trumany,
I’m using the power brick that came with the dev kit. I hooked up an amp meter and the current changes from 15.3 mA to 15.5 mA when I hold the power button down.

Seems no current change. Can it go into recovery mode by pressing recovery button and reset? If not still, i’m afraid that it has to RMA.

Unfortunately I can’t get it into recovery mode.
Thanks for your help.

Hello Trumany,

I have the same problem. Can’t see the TX2 rising up.
I measured 0.84A current.

But that’s weird because we came to work after the weekend and the TX2 won’t rise up…
It wasn’t even plugged to power, only was connected to the dev kit.

Any suggestions instead RMA?

So it can’t enter recovery mode either? And plug/unplug module from carrier board does not help? If so, looks like some components issue, RMA is necessary then.