TX2i refuses to boot after repeated debugging of broken libargus code


I’ve been debugging code for a small libargus app (IEGLOutputStream producer, IFrameConsumer consumer). The trouble was due to the fact that the producer and consumer would apparently connect, but no frames would be produced. I would run the program once, stop it, debug it, then restart the TX2 and run it again (as running it again without restarting the TX2 wouldn’t create the producer and instead timeout).

A couple of times, I forgot to stop the program from running, and I noticed a “disk low on memory warning” pop up during one of these times. The next time, when I went to save the changes to the app, vim failed to save because the disk was out of memory. I restarted the TX2, which brought me back to the login screen, but it wouldn’t let me login, instead taking me back to the login screen. When I removed the power, waited 10 minutes, then plugged it back in again, it didn’t take me back to the login screen at all, giving me the log messages pictured. It has been displaying this log message for the last 30 minutes with no change. Has anyone seen this before, and know how to boot it up again?

hello tganger,

it’s text file to store the system messages in the rootfs, you should have /var/log/syslog which exceed your file system size.
please have a try to halt the bootloader process in u-boot, enter the command, fatinfo , to check the info about file system.

The strangest thing happened: When I tried to boot it today, it just booted up! No issues or anything. I’ll mark this as resolved and make another post if I run in to the issue again.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.