I want to check the waveform of the spi.

The waveforms I want to check are the spi0, spi1 of TX2i.
spi1 wants to check the waveform with the J21 header.

So I modified it by referring to the following website.


spi@0 {
compatible = “spidev”;
reg = <0x0>;
spi-max-frequency = <0x1312D00>;
nvidia,cs-setup-clk-count = <0x1e>;
nvidia,cs-hold-clk-count = <0x1e>;
nvidia,rx-clk-tap-delay = <0x1f>;
nvidia,tx-clk-tap-delay = <0x0>;

We added this content to TX2i’s dtb file, “tegra186-quill-p3489-1000-a00-00-ucm1.dtb” and flash it with TX2i board.

/dev/spidev3.0 is enabled on the board, but the waveform does not appear.

/dev/spidev0.0 and /dev/spidev1.0 have been activated by adding the above code to the portion corresponding to spi0, spi1.

$ echo 1 > /dev/spi1.0

I connected to 19 (MOSI) / 23 (CLK) on the J21 header and checked the waveform, but it did not come out.

Is the content to be added differently for each spi0 and spi1?

Could you try to configure those pin by jetson-io to try.

I don’t know anything about jetson-io.

Please explain about jetson-io.

Just try sudo /opt/nvidia/jetson-io/jetson-io.py
Then select configure 40-pins

The command does not have an error, but does not work.

Have a check this doc.


Thank you, ShaneCCC.