UART1 Jetson Nano

Hey everyone,
I’m trying to communicate with my Jetson Nano through a RFID-rc522, through the UART module.
So far I have been able to do so when using the J41 pins, but when I try to use the J44 pins, it doesn’t work.
I’m using ttyTHS1 for the J41 pin, and ttyTHS2 for the J44 pin, tried a bunch of tips that were given in these threads, but none of them have worked so far.

Still trying so if I get any results I’ll post them here

Please refer to this post:

Hey, just wanted to say that I fixed my issue
I had to improvise and instead of using the THS2 and the j44 pin, I just switched to a USB connection between the jetson and the RFID, and in so switched to the ttyUSB0.
This allowed me to exactly what I wanted without the blunder that is the THS2.

Also post above didn’t help

Thanks for sharing the solution.
Other users have seen it working by disabling nvgetty service:

Probably some other factors triggering the error. Good to know you figure out a solution and are willing to share to other users.

I’m a veterinarian; not a programmer. We are using the NVIDIA for computer vision project and want to add a RFID component to identify animals as they move under the camera (similar to a start line of a race) Would anyone direct me to other users combining RFID, RealSense 455 cameras for computer vision with NVIDIA. In particular, I would like to know if there is code available. Thank you. M

1 Like