uboot and kernel fails to boot due to ext4

Hello,

There is a problem with ext4 on the tegra tk1, probably since the new release of mke2fs.

I flashed the board on a Debian Stretch host.

The first problem is with uboot which doesn’t support ext4 with 64 bits options so in the ./flash.sh script you have to change this lines :

#mkfs -t $4 ${loop_dev} > /dev/null 2>&1;
mkfs -t ext2 ${loop_dev} > /dev/null 2>&1;

The better solution should be to find options for mkfs to desactivate new functionalities for example :

mkfs -O ^64bits -t $4 ${loop_dev} > /dev/null 2>&1;

Sincerely yours,
Snootlab

This is a known issue…technically it could be ignored since JetPack is only intended to be on Ubuntu 14.04, but flash.sh operates on any x86_64 Linux and this is becoming a more prominent issue as more updated Linux installs get the 64-bit options. I will suggest the next release have the options to mkfs.ext4 of “-O ^64bits,^metadata_csum” (the other option is to make U-Boot aware of dealing with those options…this would be the more difficult solution). Eventually JetPack will work with a newer Linux anyway, so the future need for this is inevitable. Having this in the flash.sh script by default would eliminate the issue for those flashing on command line.