Ubuntu 12.04 and GT 610

Dear developers,
it’s few days i have bought a GeForce GT 610, to give CUDA capability to my desktop. I have downloaded and installed from the NVidia drivers the following: NVIDIA-Linux-x86_64-319.17.run. After installation i was able to compile and run in Nsight Eclipse Edition, the example called deviceQuery. After i tried the same with an other sample: nBody. I was receiving the compile error: compute_21 architecture not found, or something similar. So i have installe trough synaptic all the packages regarding cuda; cublas and others… but didn’t resolve the problem.
But at this point i was having two version of the drivers: 304 and 319 (with the latter one active). By looking at the web i have seen that there can be compiling problems if the cuda-toolkit is not up to date with the drivers. So i tried to activate the 304 version, but my graphic server got stucked.

Now i have reinstalled ubuntu form scratch, without the graphic card. After i have installed the graphic card again in the PCI express, so now i want to follow the exact steps to use CUDA in a proper way.

First question is: should i reinstall NVIDIA-Linux-x86_64-319.17.run, or is better cuda_5.5.22_linux_64.run, that is the package containing all the required software for programming in CUDA???

I’m sorry if i was too much confused, an i hope someone can help me.




There are various tutorials on how to install NVIDIA drivers available online. The easiest way to install the latest drivers is to add the xorg-edgers repository to your sources and install nvidia-319 drivers, and then install the CUDA SDK and skip the driver installation included in the package.

As for the particular error, of compute_21 architecture not found, it seems you just have to add the flag to nvcc to compile for that architecture.