Ubuntu 14.04 4x monitors 2x cards repaint issue with Unity

Hi there,

I’m so used to Unity right now, that i would like this problem to be solved. I was using Ubuntu 12.04 and xinerama with the 2 cards and 4 monitors with no acceleration (Unity 2D), no acceleration since composite was not compatible with xinerama when tried to configure it. Everything worked enough for me. Now, i’m testing next LTS 14.04 and trying it out of the box. Surprisyngly, everything works more or less fine after some arrangements, using nvidia-settings.

The only issue I can see here, is that when clicking on the Dash or the active window lose the focus, its content becomes black. This can be reverted resizing a bit the window, but it’s really annoying. It seems a repaint problem, but cannot guess where could solve it. I attach:

Nvidia-Bug-Report [url]http://nube.tourndrive.com/public.php?service=files&t=a9fd7bb9520ab7b12544ce87948acbb8[/url]
Xorg.0.Log [url]http://nube.tourndrive.com/public.php?service=files&t=7193a140b2552deb6a90d8e7d7c495e9[/url]
xorg.conf [url]http://nube.tourndrive.com/public.php?service=files&t=35f34baba9a235191b56e5a2142e118a[/url]
Screen capture [url]http://nube.tourndrive.com/public.php?service=files&t=e16f92cc5e7945b332716ed2560027c6[/url]

Thanks to anybody that can help me on this.

Well, a bit more info on this:

  • Clarify: Yes, i’m using composite+xinerama, now they seem to work together.
  • Google Chrome windows don’t go to black when lose their focus. It’s the only case.

Hi xavirp,

I just wanted to let you know that we’ve identified the problem and it should be fixed in a future release.