Ubuntu 14.04 nsight eclipse project build settings compute arch no values beyond 6.0

Using nsight eclipse CUDA 8.0 most recent drivers it will not let me directly (via the GUI) change the arch and compile options beyond the specific options in the GUI. Those end at 60 and I would like to use 61 for the GTX 1080ti.

Is there any way to do this through Eclipse IDE or do have to edit the makefile?

Sorry it looks like an oversight. I think you would have to edit the makefile. I’ve filed an internal tracking bug to get this added to a future version.

There is another way to do it also.

Create a project.
Right click on the project, select Properties in the popup menu (last menu item)
In the navigator on the left hand side of the pane that opens, expand “Build” then select “Settings”
On the right hand side of the pane, select the Tab labelled “Tool Settings”
In the middle of the pane there is a text box labelled “Expert Settings: Command Line Pattern:”

That text box should contain pre-populated text that looks like this:

{COMMAND} {FLAGS} {OUTPUT_FLAG} {OUTPUT_PREFIX} {OUTPUT} {INPUTS}

If you change it as follows:

{COMMAND} {FLAGS} -gencode arch=compute_61,code=sm_61 {OUTPUT_FLAG} {OUTPUT_PREFIX} {OUTPUT} {INPUTS}

(Note that you probably want to do this both for “NVCC Compiler” and “NVCC Linker”)
(Don’t forget to click “Apply”)

Then you should see that added when you build the project:

17:39:15 **** Build of configuration Debug for project test ****
make all 
Building file: ../src/test.cu
Invoking: NVCC Compiler
/usr/local/cuda-8.0/bin/nvcc -G -g -O0 -gencode arch=compute_30,code=sm_30  -odir "src" -M -o "src/test.d" "../src/test.cu"
/usr/local/cuda-8.0/bin/nvcc -G -g -O0 --compile --relocatable-device-code=false -gencode arch=compute_30,code=compute_30 -gencode arch=compute_30,code=sm_30 -gencode arch=compute_61,code=sm_61  -x cu -o  "src/test.o" "../src/test.cu"
Finished building: ../src/test.cu
 
Building target: test
Invoking: NVCC Linker
/usr/local/cuda-8.0/bin/nvcc --cudart static --relocatable-device-code=false -gencode arch=compute_30,code=compute_30 -gencode arch=compute_30,code=sm_30 -gencode arch=compute_61,code=sm_61 -link -o  "test"  ./src/test.o   
Finished building target: test
 

17:39:17 Build Finished (took 2s.270ms)

Yes, that worked. Thanks!