ubuntu 15.04 with nvidia-346.59 can't save screen resolution settings

hi, please forgive me for my poor english . currently, i use ubuntu 15.04 with nvidia-346.59 driver,
graphic card: geforce gtx 970m, max laptop screen resolution: 2880x1620.

with nvidia-settings utility , i can change it to 1920x1080 , and that’s ok . but this will lost after reboot.

i click “Save to X Configration File” button , this will generate xorg.conf under /etc/X11, file content like this :

Section “ServerLayout”
Identifier “Layout0”
Screen 0 “Screen0” 0 0
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”
Option “Xinerama” “0”

Section “Files”

Section “InputDevice”
# generated from default
Identifier “Mouse0”
Driver “mouse”
Option “Protocol” “auto”
Option “Device” “/dev/psaux”
Option “Emulate3Buttons” “no”
Option “ZAxisMapping” “4 5”

Section “InputDevice”
# generated from default
Identifier “Keyboard0”
Driver “kbd”

Section “Monitor”
# HorizSync source: edid, VertRefresh source: edid
Identifier “Monitor0”
VendorName “Unknown”
ModelName “Panasonic VVX16T020G00”
HorizSync 76.0 - 100.0
VertRefresh 46.0 - 61.0
Option “DPMS”

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “GeForce GTX 970M”

Section “Screen”
Identifier “Screen0”
Device “Device0”
Monitor “Monitor0”
DefaultDepth 24
Option “Stereo” “0”
Option “nvidiaXineramaInfoOrder” “DFP-1”
Option “metamodes” “nvidia-auto-select +0+0 {viewportin=1920x1080}”
Option “SLI” “Off”
Option “MultiGPU” “Off”
Option “BaseMosaic” “off”
SubSection “Display”
Depth 24

then i restart x server with command “systemctl restart lightdm”, log in , find this doesn’t work.

please help me !