Ubuntu 16.04 login loop GeForce GTX 1060

I can boot with the nouveau driver. I have tried just about every combination of nvidia driver/install methods. The results are always that I get the Ubuntu login screen, I enter my password and I am immediately taken back to the Ubuntu login screen.

Ubuntu 16.04
GeForce GTX 1060
iBuyPower Trace 940

I cannot figure out how to completely disable secure boot. But in the secure boot settings I have changed the OS Type to “Other OS”

Here is the dump when using nvidia-390:

https://drive.google.com/file/d/1DfufPubmvzSXmHKlPvhLpOI-56rt1E0C/view?usp=sharing

Thanks!

That’s a coffee lake system with hybrid graphics.
How did you install the nvidia driver? If you used the .run installer, uninstall it by calling it again with --uninstall option. Afterwards, delete your /etc/X11/xorg.conf
Then you need to upgrade your HWE stack, for coffee lake you’ll need kernel 4.15:
https://wiki.ubuntu.com/Kernel/LTSEnablementStack
Update, then check if you’re on kernel 4.15 ( https://packages.ubuntu.com/xenial/kernel/linux-image-4.15.0-30-generic)
cat /proc/version
When that’s done, use the graphics ppa to install the nvidia driver:
https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa
then make sure that the package nvidia-prime is installed
sudo apt-get install nvidia-prime
use
sudo prime-select nvidia
to switch to nvidia, reboot.

Thanks for the quick response. Things are working much better now. The monitor resolution is decent and my dual monitors are both working.

However, I do not think I am using nvidia yet. When I run the last command:

sudo prime-select nvidia

I get:

desktop:~$ sudo prime-select nvidia
[sudo] password for chuck:
Info: the current GL alternatives in use are: [‘mesa’, None]
Info: the current EGL alternatives in use are: [‘mesa-egl’, None]
Error: the installed packages do not support PRIME
Error: nvidia mode can’t be enabled

Thanks

How did you install the nvidia driver?
Please create a new nvidia-bug-report and attach.

I’m sorry. I did not understand the original instructions. I thought “sudo apt-get install nvidia-prime” installed the driver.

So I just now, I ran this code to install this driver because 390 was what the nvidia site recommended for my graphics card:

sudo apt-get install nvidia-390
sudo apt-get install nvidia-prime
sudo prime-select nvidia

This resulted in:
desktop:~$ sudo prime-select nvidia
[sudo] password for chuck:
Info: the current GL alternatives in use are: [‘nvidia-390’, ‘nvidia-390’]
Info: the current EGL alternatives in use are: [‘nvidia-390’, ‘nvidia-390’]
Info: the nvidia profile is already in use

I rebooted. Things seem to be working. Am I using the nvidia driver/hardware now??? How can I tell?

The new bug report is attached.

https://drive.google.com/file/d/1DfufPubmvzSXmHKlPvhLpOI-56rt1E0C/view?usp=sharing

Thanks

just run
nvidia-settings
the panel ‘graphics information’ - ‘OpenGL’ should display nvidia opengl 4.6

Logs look good. To have a tear-free display,
create a file /etc/modprobe.d/99-prime-sync.conf containing

options nvidia_390_drm modeset=1

then run
sudo update-initramfs -u
and reboot.

Wow - thanks. The graphics are working as they are supposed to. I am blown away by how great your help was.

One other thing that may or may not be related, after all of the above changes, my computer no longer completely powers down when I either use:

sudo poweroff

as well as the GUI shutdown button. Instead, one screen goes black, the other goes to a screen with the Ubuntu logo in the center and a progress bar that never gets past the first dot.

Any ideas how to fix that?

In case this is just a hanging process, edit /etc/systemd/system.conf
and add/change
DefaultTimeoutStopSec=10s
so blockers get killed after 10sec instead of 90sec. Reboot after that.
To debug this further, switch to VT using Ctrl+Alt+F1, login there and issue sudo halt -p
Then see what messages appear.

I was not able to catch the messages. I looked in /var/log/dmesg and /var/log/syslog but nothing jumped out at me.

However, I have noticed a new issue. I have no audio. My monitors do not have audio. I listen through speakers connected to the 1/8" audio jack. Is it possible that the graphics driver messed up the audio?

About the poweroff issue, you could also disable the ubuntu splash (plymouth) to look for messages displayed:
https://wiki.ubuntu.com/Plymouth#Debugging

Regarding audio, the video driver shouldn’t have impact on audio. According to the logs, one monitor is connected over DVI to the nvidia gpu, so that doesn’t have sound anyway. The other one is connected to the intel gpu, but the intel audio device fails:
[ 2.844501] snd_hda_intel 0000:00:1f.3: CORB reset timeout#1, CORBRP = 0
[ 2.846077] snd_hda_intel 0000:00:1f.3: no codecs found!
Don’t really know how to fix that, see if a bios update is available for your system, try creating
/etc/modprobe.d/90-sound-intel-auto.conf

options snd-hda-intel model=auto

and run sudo update-initramfs -u afterwards.
For a workaround, you could move the monitor to a different connector on the computer so you might be connceted to the nvidia audio.
hints:
paprefs allows you to enable a simultaneous audio output to all devices
pavucontrol gives fine grained output control.

All of the above was a dry run to prepare for migrating my work system. My work system was Ubuntu 14.04 on a vanilla HP desktop. Because I can live with the poweroff issue and the sound issue and the fact that all the other issues were resolved, I upgraded my work system:

  1. migrated from Ubuntu 14.04 to 16.04
  2. ran all the steps above, except message #11

After all that the poweroff issue resolved itself.

Also when I plugged in a USB headset, sound worked for it. In any case, it seems like it’s not an Nvidia issue anyway.

Thanks again for all your help!