Ubuntu 16.04 LTS + GeForce GTX 1060 - driver installation leads to login loop

Hi,
I’m trying to install the proper driver on the 2017 Razer Blade (1920x1080, i7-7700HQ 3.8GHz Kaby Lake, GTX 1060) that I just bought, but whenever I try to install the driver (I tried installing both through apt and then the driver provided by NVIDIA), it leads to not being able to log in (it just goes back to the login screen). The output of nvidia-bug-report.sh is here: http://www31.zippyshare.com/v/sy84Mdgy/file.html

Note that for some reason the pre-install failed, but I’m not quite sure why. I also noticed that, per the log I linked to, it tries to load the nvidia driver twice, so I just wanted to note that I did actually try to uninstall all nvidia-related packages (apt remove --purge nvidia*) before running the NVIDIA-provided install script.

I’m not quite sure where to go next, I did try whatever information was available on stackexchange and this forum, but nothing seemed to work for my scenario.

Thanks in advance!

You have kernel parameter
nomodeset
set. This is killing the intel gpu which you need since this is an Optimus laptop. Remove, retry. Make sure you have the package linux-firmware installed.
Don’t use the .run installer, always use the Ubuntu packages, otherwise it won’t work due to Optimus.

Also make sure the package nvidia-prime is installed.

I removed the nomodeset from /etc/default/grub and tried both the nvidia-384 and nvidia390 drivers. Logs:

Both lead to the exact same behavior! I did also double check that nvidia-prime and linux-firmware packages are installed.

P.S. I really appreciate the super quick response!

Also, just to be clear, when I ran ubuntu-devices drivers, it showed nvidia-390 being recommended

You still have nomodeset in kernel cmdline.
Forgot to run
sudo update-grub
?
Use
cat /proc/cmdline
to outpu current parameters.

Holy crap, it works!

THANK YOU! And thanks for catching my really naive mistake!