Ubuntu 16.04 NVIDIA graphics card driver installation problem

I first installed driver 390.48. Then when I installed CUDA 9.0, it installed driver 387 automatically. I had to uninstall 387 and install 390.48 again. I could run nvidia-smi but always got some output with problems. The output is shown here.

±----------------------------------------------------------------------------+
| NVIDIA-SMI 390.48 Driver Version: 390.48 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 NVS 310 Off | 00000000:03:00.0 N/A | N/A |
| 30% 59C P0 N/A / N/A | 0MiB / 452MiB | N/A Default |
±------------------------------±---------------------±---------------------+
| 1 TITAN X (Pascal) Off | 00000000:04:00.0 Off | N/A |
| 0% 43C P0 53W / 250W | 0MiB / 12196MiB | 0% Default |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Processes: GPU Memory |
| GPU PID Type Process name Usage |
|=============================================================================|
| 0 Not Supported |
±----------------------------------------------------------------------------+

Then when I tried to install tensorflow, it always failed when trying to create Session.

My guess, you’ll have to use CUDA_VISIBLE_DEVICES to mask the NVS:
http://acceleware.com/blog/cudavisibledevices-masking-gpus

Thanks for the answer. I may try that later. I took out the NVS 310 to get work around now.