Ubuntu 16 based distros no input on monitor with nvidia drivers installed

I have spent hours now trying to get my GTX 970 working in Mint and/or Ubuntu Mate, whenever I install the driver I get a black screen then no input signal on my monitor, and the only way to get back into a graphical interface is to sudo apt-get purge nvidia. I have tried various driver versions (all in the 36x range), from the distros driver setting and via command line, they install fine request a reboot and then its a no input screen. I’ve tried all my ports (including my Haswell integrated graphics) to no avail. I’ve reinstalled distros a few times, and am pretty much out of ideas. What is the recommended steps to troubleshoot this? Should I try a 35x driver, I’m almost thinking my problem is unrelated and the driver is installing fine.

Hi BobbyDoogle

I think this is the same problem that is described here:
https://devtalk.nvidia.com/default/topic/941096/linux/ubuntu-16-nvidia-36x-drivers-black-screen/
https://devtalk.nvidia.com/default/topic/937319/367-xx-980m-w-4k-screen-lock-up-at-boot-ubuntu-16-10-/

Unfortunately, I couldn’t find any solution either :-(

May I ask where do you get your drivers from? Also follow the sticky link in this fourm to know how to generate a bug report.

Hey in Ubuntu and Mate I had this issues getting the driver from the driver settings menu, with the suggested 36x driver from the distro. After having this problem I also tried getting them from the command line, and I tried to download them directly from NVidia.

It doesn’t matter where I install the Nvidia drivers from (synaptic, nvidia.com driver download, ubuntu “additional drivers”) or which driver version I try, it always ends up in a black screen.

Stephan, to confirm we have the same problem do you get a no input signal or a black screen. I’m getting no input, you may be getting a black screen (with input), or is it the same?

I have resolved my issue, which I’m tempted to say is NOT a nNvidia issue, although perhaps the driver could make this easier.

Long story:
For me, there was never a driver installation error, simply after (Ubuntu Mate / Mint / Etc.) loading screen it would go to no input screen after a slightly longer load. I had previously tried plugging in monitor(s) to all my cards (and integrated gfx) outputs to see if a different port was outputting the signal then the monitor was set to, with no success. I tried installing the driver from nVidia, the driver management (distro based) and synaptic manager, no success.

Solution / Short Story:
After installing the drivers if I have an HDMI cable cable plugged in during boot, my monitor will detect the signal and I will get to the distro desktop with nVidia drivers. Having a display port plugged in will not, and plugging the HDMI in after boot will also not work. So, basically as long as I have the monitor set to HDMI and the cable plugged in at boot it goes well.

As a side note, on Windows, from time to time, I need to unplug / replug my display port connection in get it to detect. In this case it doesn’t matter if it is during boot / etc. just that I unplug and replug the connection, again unrelated to Linux, but perhaps there is something with either my monitor (ASUS PB278Q 27-Inch WQHD LED-lit Professional Graphics Monitor) and nVidia that makes port detection tricky.

Hopefully this helps someone, I’ll close this thread, I believe it is different then the black screen issues other report.

no signal, so we have the same problem.