Ubuntu 18.04.3 blank screen at startup with 430 drivers and GTX 960

For some reason, my computer running 18.04 LTS, kernel 5.0.0-36 doesn’t show a login screen anymore on booting up – it boots up until it seems to load the desktop and then it doesn’t. It worked fine just yesterday with kernel 5 and the 430.50 drivers, and I’m not quite sure what has changed.

When I set prime-select on intel I am able to login, but then the nvidia drivers aren’t recognised – nvidia-smi gives me the following error: “NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.”

When I set prime-select on nvidia, the startup issue described above occurs. I’ve generated a bug report while prime-select is on nvidia and attached it.

This is the dkms status output:

“nvidia, 430.50, 5.0.0-36-generic, x86_64: installed
virtualbox, 5.2.32, 4.15.0-70-generic, x86_64: installed
virtualbox, 5.2.32, 5.0.0-36-generic, x86_64: installed”

I’ve purged the drivers and installed them again, trying that for several different versions of the drivers (including 390 and 440). I’ve also tried to downgrade to a earlier kernel to no avail. But like I said, it worked fine earlier on kernel 5 and drivers 430.50.

The nouveau drivers do seem to work (but only when I purge the other drivers) but of course don’t give me the performance I need.

Any advice?

Looks like you ran into a driver bug with 430.50 where the gpu thinks it has no outputs. Try adding the graphics ppa and update to 440. Alternatively, run

grep nvidia /etc/modprobe.d/* /lib/modprobe.d/*

to find a file containing

options nvidia-drm modeset=1

and change 1 to 0
then run

sudo update-initramfs -u

and reboot.

It worked! I tried the 440 drivers before to no avail, so I was a bit hesitant to use those. Instead, I changed the modeset value to 0 as suggested and it works again. After spending hours on this yesterday, it was just a simple boolean. You are my hero, thank you.

after I run
grep nvidia /etc/modprobe.d/* /lib/modprobe.d/*

The result I get
/etc/modprobe.d/blacklist-framebuffer.conf:blacklist nvidiafb

looks like couldn’t find the file containing
options nvidia-drm modeset=1