Ubuntu 18.04 cannot boot after installing recommended nvidia driver 470


I recently installed ubuntu with a bootable drive on a windows computer. However it is only ubuntu and not dualboot. Now I want to install nvidia drivers on my laptop to use GPU for Deep Learning algorithms. I tried a lot of different things I saw online but none of them worked so I am finally writing a post here. I did prime select nvidia and updated initramfs before reboot, I tired repo and ppadrivers and also tried changing grub defaultm parameters like nomodeset parameters but nothing worked. I can only reboot normally after purging every nvidia file from the recovery mode. I also want to precise that my Ubuntu is UEFI but I disabled secureboot.
I have one example of log here :
nvidia-bug-report.log.gz (254.0 KB)

Thank you very much for your help.

  • run
sudo prime-select nvidia
  • run
grep nvidia /etc/modprobe.d/* /lib/modprobe.d/*

to find a file containing

blacklist nvidia

and remove it,
then run

sudo update-initramfs -u

and reboot.

First, thank you very much for your time and quick reply.

I did what you wrote. I prime selected nvidia. I found this file blacklist-framebuffer (the first one)
that I deleted, then updated initramfs but I still could not reboot. On recovery mode I created this new log :
nvidia-bug-report.log.txt (226.7 KB)

Thank you for your help.

Those files are actually needed. Nevertheless, the nvidia driver now loads but now the problem is your intel gpu. The ubuntu 18.04 stock kernel iss too old to drive it, please try upgrading kernel+firmware using the liquorix ppa and the updated firmware package

I followed what you recommended. I got back the blacklist-framebuffer.conf that I deleted before because it was necessary for the boot. I updated initramfs, installed linux 5.17 liquorix rebooted, installed nvidia driver a new time and now apparently I can boot with nvidia driver installed! So thank you for that.
However, I still get this error when running nvidia-smi :

So I ran another bug report :
nvidia-bug-report.log.txt (120.9 KB)

Please reinstall the headers
sudo apt-get install --reinstall linux-headers-$(uname -r)
and post the output of
dkms status

I reinstalled linux headers for liquorix and I installed dkms package since I did not have it and so there is no output to dkms status. I guess there is no output to dkms status (and also dkms status linux-headers-$(uname -r) ) because I did not install everything with dkms on my system.

Please install the dkms part of the driver
sudo apt install nvidia-dkms-470

I installed nvidia-dkms-470, rebooted. It works now. I can see an output for nvidia-smi command. Thank you very much! I will never have succeeded without your help and time.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.