Ubuntu 18.04 has 2 graphic Radeon and Nvidia RTX 2060 still uses llvmpipe

Hi. I’ve installed ubuntu 18.04 on my Laptop which is ASUS TUF Gaming A15. It has 2 graphic cards: Nvidia Geforce RTX 2060 and AMD Radeon. I installed Nvidia graphic card driver in several ways but it still uses llvmpipe. I disabled secure boot, installed graphic card through Ubuntu’s Software and Update, repositories, downloaded driver from Nvidia website, changing configuration in /etc and /usr directory. After trying different ways suggested in this forum, I’m still stuck in this situation.

The output of nvidia-smi :

    ruzuntu@Ruzuntu-TUF-FA506IV:~$ nvidia-smi
    Mon Dec 14 14:46:01 2020       
    | NVIDIA-SMI 455.38       Driver Version: 455.38       CUDA Version: 11.1     |
    | GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
    | Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
    |                               |                      |               MIG M. |
    |   0  GeForce RTX 2060    Off  | 00000000:01:00.0 Off |                  N/A |
    | N/A   48C    P8     5W /  N/A |     10MiB /  5934MiB |      0%      Default |
    |                               |                      |                  N/A |
    | Processes:                                                                  |
    |  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
    |        ID   ID                                                   Usage      |
    |    0   N/A  N/A      1195      G   /usr/lib/xorg/Xorg                  4MiB |
    |    0   N/A  N/A      1737      G   /usr/lib/xorg/Xorg                  4MiB |

the output of “glxinfo |grep vendor” :

ruzuntu@Ruzuntu-TUF-FA506IV:~$ glxinfo |grep vendor
server glx vendor string: SGI
client glx vendor string: Mesa Project and SGI
OpenGL vendor string: VMware, Inc.

The output of “sudo prime-select nvidia” :

Info: the nvidia profile is already set

I also attached the Nvidia bug report. nvidia-bug-report.log.gz (314.8 KB)
I’ve been struggling with this problem for months so I’ll be really glad if someone can help me.

update: when I open additional driver in Ubuntu update, it always says unknown.

The main problem is that you’re using Ubuntu 18.04, the included kernel 5.4 doesn’t support your AMD gpu, it’s too new for that. Without that, nothing works. You’ll have to either upgrade to Ubuntu 20.04 or install a more recent kernel.
Afterwards, you can decide if you’ll want to use Prime offload or output (might need additional tweaking).

1 Like

Thanks for your reply. I tried kernel 5.6 and 5.7 but after installing and restarting, I will stick in black screen. because of some codes that can only be compiled in 18.04 and below, I can’t upgrade to 20.04. Do you have any other suggestions?

It’s a bit outdated, but these are the kernel components to install:
You could try if that helps and then try using a more current 5.9 kernel.

Hi. thanks for your advice. I installed kernel 5.6 through your instructions and even installed kernel 5.9. both of them would lead to this error page which comes up after restart. I can’t figure out what to do with it.
I read it might be because of the old bios version but I’m pretty sure that I update it recently.

I guess the error messages by itself are a red herring, normal errors that can be displayed during boot. I suspect with the AMD gpu now active, some weird config comes into play, starting an Xserver on a not available monitor.
Can you get to a login by pressing ctrl+alt+f2 [or f3,f4…]?
if so, login and create a new nvidia-bug-report.log
Otherwise, reboot to the stock kernel and immediately after boot, create the log.

unfortunately, I don’t have access through ctrl+alt+f(). as you said, I tried kernel 5.6 and after blackout restarted, then created this log.nvidia-bug-report.log.gz (622.4 KB)

Ok, the kernel runs fine but X tries to start on the Nvidia so you don’t see anything. I suspect the AMD gpu is missing the correct firmware files. Please run

sudo journalctl -b-1 |grep kernel >kernel.txt

to get the dmesg from last boot (the boot with 5.6) and attach kernel.txt

ok. here’s the result:
kernel.txt (114.7 KB)

As I suspected, just download the firmware and put it in the correct directory:

thanks. I downloaded and copied renoir_gpu_info.bin to /lib/firmware/amdgpu and then tried 5.6 and 5.9 kernel. unfortunately, nothing changed. I attached the new kernel.txt and Nvidia bug report.
kernel.txt (117.0 KB) nvidia-bug-report.log.gz (1.1 MB)

Looks like you have a newer device that also needs the additional firmware files
Better download all files that begin with renoir and put it into the firmware directory.

ok. I copied all of the files with renoir prefix. The good news is I finally got to login into ubuntu. screen is flashy (turning on and off periodically) and graphics in settings is now changed into “AMD® Renoir”. I attached the kernel.txt and Nvidia bug report.
kernel.txt (112.9 KB) nvidia-bug-report.log.gz (866.9 KB)
in “Software & Updates > Additional driver” it still says Nvidia Corporation: Unknown

Please check if running as root

 echo "high" > /sys/class/drm/card0/device/power_dpm_force_performance_level

fixes the flashing.
Ubuntu 18.04 is too old to auto-detect the nvidia gpu but this doesn’t matter, the driver is installed and running fine.
You can now continue to configure the nvidia gpu to be used:

Thanks a lot! I can finally see “GeForce RTX 2060/PCIe/SSE2” in system detail. but the flashy screen is still bothering me.

Did you try setting the performance level? Instead of high you can also try ‘low’.
Also, you could check if setting the screen refresh rate changes it, see: