Ubuntu 18.04 has experience an internal error

This occurred right after boot-up while the system was idle. Not the first time its happened.

Title: nvargus-daemon crashed with SIGSEGV

Executable path:

/usr/sbin/nvargus-daemon

StacktraceTop:

?? () from /usr/lib/aarch64-linux-gnu/tegra/libnvargus.so
?? () from /usr/lib/aarch64-linux-gnu/tegra/libnvargus.so
?? () from /usr/lib/aarch64-linux-gnu/tegra/libnvargus.so
?? () from /usr/lib/aarch64-linux-gnu/tegra/libnvargus.so
?? () from /usr/lib/aarch64-linux-gnu/tegra/libnvos.so

Let me know if I need to provide more information. I saved the crash report.

Do you have a camera plugged in by chance? Will it boot without the camera connected?

Happens with or without camera. The system boots fine. If the error never popped up, I wouldn’t realize anything is wrong.

I have the exact same thing happen to me, with a Jetson Nano that has been booted for the first time off the Deep Learning Institute DLINANO image.

I haven’t experienced this issue in a while. Unfortunately, I actively did nothing to fix it. It just stopped happening. A software update may have fixed it.

I’m experiencing the same problem with my Jetson Nano. I have installed a Raspberry Pi V2 camera, but the error pop ups with or without the camera. Ubuntu 18.04 with the last update

That’s a pretty common error in Ubuntu in general. Unless something else is going on that’s causing a problem, it can safely be ignored. It just means that some program has crashed, and if you want you can send the crash report to the developers (please do this). There is a similar error on Windows but I can’t remember the exact wording.

Here is an article explaining more about the error, including how to turn the dialog off, but it’s best to report these sorts of errors so they can be fixed (unless you’re in a situation where you’re not allowed to).

I sent it. After sending the report I tried to resize a window and the system got frozen completely. I unplugged the power supply to restart the system.

The crash reports should be in /var/crash if you’re interested in what might have caused that.

1 Like

Thanks!!

You might also try connecting with serial console after a lockup to see if you can view dmesg. Serial console tends to survive many crashes which the local terminal can’t handle. See:
https://www.jetsonhacks.com/2019/04/19/jetson-nano-serial-console/

You can even run serial console prior to a lockup and have an advantage since whatever occurs up to the point of system death remains on the console for copy. So for example at start you could connect serial console and run “dmesg --follow”.