Ubuntu 18.04 LTS boot up time increases by over 100% after installing Nvidia Drivers

Hi

I’m using Ubuntu 18.04 LTS release and has installed Nvidia 390.48 drivers via “Additional Drivers” section.

After installing drivers, my Ubuntu boot-up time has increased by over 100% (By more than 15 seconds to 25+ seconds).

In between when there’s a lag for 15+ seconds then my display on monitor turn purple (Purple as on Ubuntu boot-up screen), and then when that lag ends, there’s a “beep” from PC which is similar to the “beep” one hears from PC when the system gets restarted and ONLY then the login screen appears.

Without the drivers, my system boots up in less than 10 seconds and the lag of 15+ seconds with purple screen does not happen. With Nvidia Drivers, the lag happens, and boot up time increases to more than 25 seconds.

I’ve installed my Ubuntu in legacy mode and NOT in UEFI mode due to certain problems that Nvidia drivers was having in UEFI mode in my PC. I’m happt with this.

My PC Specs:
Core i3 4160
12 GB RAM
Gigabyte GA-H81M-S
120 GB Kingston SSD (Ubuntu 18.04 is installed here)
1 TB WD HDD (For storing data, no OS here)

Here’s some info for one to consider (I’ve highlighted the problem parts in ORANGE color) :

systemd-analyze critical-chain
The time after the unit is active or started is printed after the “@” character.
The time the unit takes to start is printed after the “+” character.

graphical.target @27.419s
└─multi-user.target @27.419s
└─getty.target @27.419s
└─getty@tty1.service @27.417s
└─system-getty.slice @27.416s
└─setvtrgb.service @27.410s +5ms
└─systemd-user-sessions.service @1.655s +4ms

        └─network.target @1.654s
          └─NetworkManager.service @980ms +673ms
            └─dbus.service @854ms
              └─basic.target @832ms
                └─sockets.target @832ms
                  └─snapd.socket @830ms +2ms
                    └─sysinit.target @790ms
                      └─apparmor.service @304ms +485ms
                        └─local-fs.target @303ms
                          └─local-fs-pre.target @287ms
                            └─keyboard-setup.service @167ms +120ms
                              └─systemd-journald.socket @160ms
                                └─system.slice @160ms
                                  └─-.slice @158ms

~

:~$ systemd-analyze blame
25.745s lightdm.service
25.744s plymouth-quit-wait.service
25.534s NetworkManager-wait-online.service
7.992s apt-daily.service
2.442s apt-daily-upgrade.service

      1.355s dev-sda1.device
       771ms dev-loop1.device
       684ms dev-loop0.device
       683ms fwupd.service
       682ms ModemManager.service
       673ms NetworkManager.service
       649ms dev-loop2.device
       639ms dev-loop5.device
       618ms snapd.service
       611ms dev-loop3.device
       597ms udisks2.service
       552ms networkd-dispatcher.service
       550ms dev-loop4.device
       546ms accounts-daemon.service
       485ms apparmor.service
       466ms networking.service
       409ms grub-common.service
       376ms alsa-restore.service
       279ms polkit.service
       270ms apport.service
       255ms gpu-manager.service
       242ms systemd-resolved.service
       240ms systemd-udevd.service
       238ms systemd-timesyncd.service
       232ms systemd-journal-flush.service
       215ms hddtemp.service
       186ms avahi-daemon.service
       175ms thermald.service
       172ms snap-gnome\x2dcharacters-69.mount
       161ms rsyslog.service
       160ms lm-sensors.service
       156ms pppd-dns.service
       150ms libvirtd.service
       145ms snap-gnome\x2d3\x2d26\x2d1604-59.mount
       124ms rtkit-daemon.service
       120ms keyboard-setup.service
       107ms systemd-logind.service
       106ms snap-gnome\x2dlogs-25.mount

Did you try 396.x ver ?
https://devtalk.nvidia.com/default/topic/533434/linux/current-graphics-driver-releases/post/5255728/#5255728

I just installed 396 NVIDIA drivers. It was hell of an experience that lasted for 3 hours.

Anyway, with the new drivers, boot-up time problem got solved. My Ubuntu booted in 8 seconds flat. But, Cinnamon Desktop started crashing before it could even start. Then I switched to Cinnamon (Software rendering) and when I logged in, I couldn’t see any icons or panels or anything at all but few of my start-up applications that I have added, their windows did popped out. But apart from them, there were no icons or panels. lol

Just uninstalled 396 drivers.

on elcapitan it tooks 7 sec until the login prompt …brave boot .

Problem solved :

396 drivers doesn’t have this bug of increasing boot time by 100%.

So, I installed Fedora 28.

Updated all packages (Cinnamon 3.8 is available in its official repositories) and kernel to 4.16.3.

Installed Nvidia 396.24 manually and now everything works perfectly.

So, this combination works :
Linux 4.16.6 kernel
Cinnamon 3.8
Nvidia 396.24 (ONLY THIS NVIDIA DRIVER SUPPORTS LINUX KERNEL 4.16.X fully)

No boot time bug and system runs smoothly. Haven’t tested games yet though.

Packages, kernel and other stuff in even the latest Ubuntu is old. Like it ships with Cinnamon 3.6.7 while other distros like Fedora already have Cinnamon 3.8.

NOTE : Cinnamon 3.6.7 have problems with combination of Nvidia 396.24 and kernel 4.15. I learned this yesterday when I was on Ubuntu 18.04