Ubuntu 18.04LTS does not detect HDMI display

Dear,

My laptop (Precision 7540) seems not able to connect to the HDMI display.
Here is the nvidia bug report.

Any thoughts on what this may occur?
Thanks!

System seems fine, did you try a different cable/monitor?

1 Like

Yes, I did. BTW, the two cables and two screens I have are working with my other laptop – I believe this is not the issue.
I’ve also noticed that the NVIDIA settings is ‘too simple’ for the version of the driver I have. (see link 1).

It’s also interesting that once I type nvidia-settings, I get the attached image saying ‘unable to find display on available system’ (link 2). In addition, it seems my computer is using the onboard intel graphic card instead of the HDMI. I believe this is the underlying reason for not having it work properly. (see link 2)

link 1: https://drive.google.com/file/d/19Tb1kxGGeGDJlYzleS8XU_KUjK6yTEB8/view?usp=sharing
link 2: https://drive.google.com/file/d/1qYAwelhkMNuTDufdmJQ7k4K5vm_46vg1/view?usp=sharing

You might be running a Wayland session:
https://askubuntu.com/questions/975094/how-to-disable-wayland-in-17-10-in-gdm3-login-screen

1 Like

Thanks!

I’ve done that. Let me emphasize that now it is working, but ONLY if instead of using nvidia-driver-440 (proprietary, tested) I use the nvidia-driver-435 (proprietary).

Do you know the reason?
In addition, can I somehow make sure I’m using the NVIDIA graphic card instead of the onboard from Intel?

The driver version shouldn’t matter, normally. You could create a new nvidia-bug-report.log with the 440 driver installed.
You can run
glxinfo |grep vendor
to check if the nvidia gpu is in use.

1 Like

Actually the report I sent you first was obtained using the nvidia-driver-440 (proprietary, tested).
Anyway, thanks for the whole help. It seems I’m using the nvidia indeed

glxinfo |grep vendor
server glx vendor string: NVIDIA Corporation
client glx vendor string: NVIDIA Corporation
OpenGL vendor string: NVIDIA Corporation