Ubuntu 19.04 doesn't detect my HDMI display

You shouldn’t do that, unless you chose to use dkms, the driver will break when you get a kernel update and you won’t get driver updates.
Please uninstall the .run driver using the --uninstall option, reinstall the driver from Ubuntu’s repo, then just delete the files
/lib/udev/rules.d/50-pm-nvidia.rul
/lib/udev/rules.d/50-pm-nvidia.rules

Hi!

I have dell inspiration 5558 (NVIDIA GeForce 920M - Intel HD Graphics 5500) and tried to connect a Samsung SyncMaster (VGA output) with HDMI converter ( i tried 2 type of cabel, but doesn’t work).

I use Ubuntu 18.04.4 LTS.
NVIDIA Driver Version: 440.82

> xrandr

HDMI-1-1 disconnected (normal left inverted right x axis y axis)

prime-select query
nvidia

Could you help me?
Thank you!

nvidia-bug-report.log (1.1 MB)

Still a problem?

Hi,
I have done all steps, all looks good
dont have xorg file
dont have modeset
prime select query is nvidia

but my device is not working properly, please help me.

nvidia-bug-report.log (810.6 KB)

Looks like prime-select/gpu-manager thinks it’s running in “on-demand” mode. Please run
sudo prime-select nvidia
again and reboot.
If that doesn’t help you cann add
Option “PrimaryGPU” “Yes”
inside the output class of /usr/share/X11/xorg.conf.d/10-nvidia.conf as a workaround.

Hello, I have a similar problem, my MSI GS65 with a GTX1070 mobile, doesn’t detect any display, in hdmi or displayport. I’m running pop os 20.04, which i suspect isn’t that different from ubuntu 19.10.
I’ve tried this and this allready, maybe I’ve done something wrong, or it isn’t my problem. I would appreciate if somebody could help me.
Here’s is my bug file.nvidia-bug-report.log (2.3 MB)

Everything seems to be fine, the nvidia gpu is running, all outputs are visible and enabled but no monitor is detected.
Did you create the log with an external monitor connected?

Nope, that may be the reason why.
Now it’s working, but I’m sure it wont last all day, since I haven’t done anything overnight and now it’s working.
It is doing as in the last couple days, where it just worked for some time but when i suspend it or try to plug in the third monitor and adjust the position of all three in the gnome-settings app, (including the orientation) it stops detecting the external ones, will see, for now it is working…
Anyways here I leave the bug report with it both connected, in case it helps. Thanks for the help.nvidia-bug-report.log (2.4 MB)

Hello, it is being working for the last couple days, but now the middle and primary monitor doesn’t show anything. I’ve run the bug report again with both connected. I reported a different situation two days ago, but I think I answered to the general topic not to your answer. Today it seems like they are all setup, but the primary display doesn’t turn on, I can move the mouse inside it and there are apps opened in that monitor though.
Please take a look if you can.
nvidia-bug-report.log (3.1 MB)

Nothing in the logs. At the time you were creating it, both monitors were detected fine and used.
Faulty monitor? Did you try disconnecting /reconnecting power to it when the issue happens?

It looks like it is something about HDMI compatibility, I’ve previously being using it with HDMI on Windows 10 and it always worked, and also works with other machines.
I switched the HDMI cable ends, changed the monitor, changed the cables, and what always happens is that the laptop detects it and shows it up in the gnome settings and I can actually move inside that monitor an put windows in there, without seeing anything, the monitors say “no signal detected”, and turn into standby mode. For the displayport I use a regular displayport cable that came with the display conected to an adapter to mini displayport, which works, but if I use that same adapter with the HDMI cable it doesn’t show up.
Super weird, yesterday it worked all day just fine, idk what has changed overnight.

Might be an unreliable hdmi socket where the data lines lose connection but the ddc lines work so it’s detected but doesn’t display anything. Gently move the connector up and down and check if that reconnects the data lines.

I got a new laptop (Ryzen4800h + nvidia 2060). The laptop is connected to two external 1080p monitors. All 3 monitors (laptop display+hdmi+dp-via-usbc) work fine on windows, but it does not detect all monitors under a dual-boot Ubuntu 18.04.4 linux + nvidia-drivers-440 (5.3 kernel, set nvidia as primary, disabled modsetting, disabled secure boot, blacklisted nouveau).

The nvidia bug report file is attached. Only one monitor is detected and used.

Appreciated if you can share a workaround.

nvidia-bug-report.log (1.0 MB)

fangq@invocation:~$ xrandr -q

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
DP-0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 477mm x 268mm
   1920x1080     60.00*+  59.94    50.00  
   1680x1050     59.95  
   1600x1200     60.00  
   1440x900      59.89  
   1440x576      50.00  
   1440x480      59.94  
   1280x1024     75.02    60.02  
   1280x960      60.00  
   1280x720      60.00    59.94    50.00  
   1152x864      75.00  
   1024x768      75.03    70.07    60.00  
   800x600       75.00    72.19    60.32    56.25  
   720x576       50.00  
   720x480       59.94  
   640x480       75.00    72.81    59.94    59.93  
DP-1 disconnected (normal left inverted right x axis y axis)

fangq@invocation:~$ nvidia-smi

Wed Jun  3 13:30:34 2020       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 440.82       Driver Version: 440.82       CUDA Version: 10.2     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce RTX 2060    Off  | 00000000:01:00.0  On |                  N/A |
| N/A   43C    P8     7W /  N/A |    432MiB /  5934MiB |      3%      Default |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|    0       975      G   /usr/lib/xorg/Xorg                           245MiB |


fangq@invocation:~$ sudo prime-select query
nvidia

Please see this:
https://forums.developer.nvidia.com/t/ubuntu-18-04-second-monitor-couldnt-be-detected-using-nvidia-430-form-ppa/125606/3?u=generix

thanks for the pointers. if I use my nvidia gpu as the primary gpu (setting “PrimaryGPU” to “yes” in 10-nvidia.conf), do I still need a 5.6 kernel for the AMD gpu to work? (by the way, amd gpu does work if I set primary-select intel, but it also sees only 1 display).

@generix, I just installed the 5.6 kernel deb files, reinstalled nvidia-driver-440, and added PrimaryGPU yes in 10-nvidia.conf, added the two optimus.desktop files, rebooted several times, but I still have the same issue running this new kernel.

my updated log file is attached. any additional change I need to make?

nvidia-bug-report.log (1.0 MB)

Please remove ‘nomodeset’ kernel parameter, it turns off amdgpu.

yes, I previously had "nvidia-drm.modeset=1" in grub’s kernel parameter, however, after setting it to 0, I still can’t see other screens.

the updated log file is attached here.

nvidia-bug-report.log (979.8 KB)

You’re missing the amdgpu firmware:

[    3.778567] amdgpu 0000:05:00.0: Direct firmware load for amdgpu/renoir_gpu_info.bin failed with error -2
[    3.778570] amdgpu 0000:05:00.0: Failed to load gpu_info firmware "amdgpu/renoir_gpu_info.bin"
[    3.778576] amdgpu 0000:05:00.0: Fatal error during GPU init

Like mentioned in the other thread I linked to, it is not advisable to do this on 18.04. Besides having a compiler mismatch, you’ll have to copy over the missing renoir firmware files from https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/tree/amdgpu
to /lib/firmware/amdgpu.

Afterwards, run
sudo update-initramfs -u