Ubuntu 19.10 card GeForce 820M, no response by both nvidia-smi and ubuntu-drivers

I tried to follow what seen in this topic, as the model is similar, with no success.
Even before installing, sudo ubuntu-drivers devices never returned output, nor in Software & Updates the video card was ever mentioned
Laptop Acer V3-572G-701f
NVIDIA GEFORCE 820M
Disabled secure boot
Installed nvidia-driver-440 via apt

~$uname -a
Linux eugeniopino-acer 5.3.0-45-generic #37-Ubuntu SMP Thu Mar 26 20:41:27 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

~$lspci | egrep 'VGA|3D|Display'
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
04:00.0 3D controller: NVIDIA Corporation GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M] (rev a1)

~$dkms status
nvidia, 440.64, 5.3.0-45-generic, x86_64: installed

Removed /lib/modprobe.d/blacklist-nvidia.conf, updated with sudo update-initramfs -u and rebooted, still

~$nvidia-smi
NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

Settings starts up and prime-selects returns “nvidia”, but
~$nvidia-settings
ERROR: NVIDIA driver is not loaded
ERROR: Unable to load info from any available system

Should I blacklist nouveau? Should I disable Wayland?
Thank you in advance.

nvidia-bug-report.log (88.8 KB)

You have a GF117M chip, meaning it’s a Fermi generation device which is only supported up until the 390 legacy driver. Just switch the driver version in Ubuntu’s Software&drivers application.

How should I accomplish that? The “Additional Drivers” section in Software and Updates doesn’t detect presence of any video card driver. See screenshot

I tried time-shifting back to before 440, installed nvidia-driver-390, rebooted and nvidia-smi couldn’t communicate. Then tried removing /lib/modprobe.d/blacklist-nvidia.conf and suddenly can’t boot in graphical mode; stuck in the login loop problem. Tried booting changing kernel parameters: adding nomodeset doesnt’ work, nor nouveau.modeset=0. Booting in console mode allowed me to disable Wayland, but still stuck on login.
What should I do? Now I switched back to a nvidia-clean version, still additional drivers doesn’t detect video card driver as in screenshot again, same output as in the post.
Thank you in advance

That’s very odd that the Nvidia drivers don’t show up in Software&Updates.
To get around the login loop when the 390 driver is installed, please try this:

grep nvidia /etc/modprobe.d/* /lib/modprobe.d/*

to find a file containing

options nvidia-drm modeset=1

and change 1 to 0
then run

sudo update-initramfs -u

and reboot.

That option's flag was already set to 0. I tried switching it to 1 and back to 0, updating every time and rebooting, still no nvidia-smi output.
New log report generated after this
nvidia-bug-report.log (88.3 KB)

Furthermore, I tried toghether, the following:

  1. Removing /lib/modprobe.d/blacklist-nvidia.conf
  2. Uncommenting #WaylandEnable=false in /etc/gdm3/custom.conf

and rebooting, still stuck on login.
I generated another bug report while stuck on login, rebooting changing kernel parameters (removing load_video and gfx* lines, and with only ro 3 on linux entry)
video_disabled_nvidia-bug-report.log (92.4 KB)
How should I proceed further? Thank you

The driver is correctly installed but there seems to be some config file missing and an xorg.conf in place while it shouldn’t. Unfortunately, those are not included in the log. Please run
find /etc/X11 /etc/X11/xorg.conf.d /usr/share/X11/xorg.conf.d -name "*.conf" -print -exec cat '{}' \; >allconfig.txt
and attach the created file ‘allconfig.txt’.

There you are. Actually folder /etc/X11/xorg.conf.d was not present.
allconfig.log (7.9 KB)

Ok, the correct file is there, you just have an xorg.conf which blocks it.
Please delete /etc/X11/xorg.conf

Wonderful, now it’s working! Thank you so much! How should I check the nvidia card is performing correctly? Actually, the Additional Drivers section still doesn’t show the nvidia drivers. Can this be fixed?

running
glxinfo | grep vendor
should return “NVidia Corporation”
As to the S&U application, no idea, never had that, also don’t know where that gets its list from. Maybe ask in the Ubuntu forums.

I definitely will ask. Thank you, meanwhile!