Ubuntu 20.04.1 lts driver & kernal has different version conflict

I think so, after all the whole ZFS file system was experimental and still being worked through.

Is this how I was to revert settings??

len@len-Z390-AORUS-ULTRA:~ sudo zfs set overlay=off canmount=off bpool len@len-Z390-AORUS-ULTRA:~

yes.
if you feel experimental, I thought you could enable the overlay and canmount again and mount the bpool and do a grub-install (man grub-install for more) there… but that might also break things totally… maybe better to ask the ubuntu guys first ;)

Might be something worth trying before a new install, I will see what Ubuntu forums have to say about this issue, now I think its beer O’Clock again, most of Monday going to be taken up on this. Good night, thanks again for your help, cheers

You’re welcome - cheers!
Let us know if you find a solution.

1 Like

Hi Mart

I found a partial solution that got my normal system back, and NVIDIA X Server Settings application up again. I have duel screen settings and 1920x1080 resolution functioning properly again.

The Nvidia 455.38 driver, (proprietary tested and recommended for Ubuntu 20.04.1LTS) is working with the 5.4.0-21-generic, x86_64: kernel installed.

len@len-Z390-AORUS-ULTRA:~ uname -r 5.4.0-21-generic len@len-Z390-AORUS-ULTRA:~ dkms status
nvidia, 455.38, 5.3.0-42-generic, x86_64: installed
nvidia, 455.38, 5.4.0-21-generic, x86_64: installed
nvidia, 455.38, 5.4.0-54-generic, x86_64: installed
len@len-Z390-AORUS-ULTRA:~$

I found this article-

I was going to do a reinstall, as every time I rebooted my system I got an initramfs failure, failuer to decode, it has been like that since I upgraded from Ubuntu 19 to 20.04 LTS. I did not at that time look into the issue as it continued on through the reboot and booted fine, originally, untill the update to Ubuntu 20.04.1

Looking at the article I noticed this command- update-initramfs -c -k all

I could not resist, I run the command not even using a live cd/USB, rebooted and it worked!

The initramfs failure, failuer to decode is now gone from the reboot sequence, and Nvidia driver, 455.38, and kernel 5.4.0-21-generic, x86_64 play nice and everything works better and faster.

I love it when stuff works better and faster.

So at this stage, I am happy all is working, I am not too fused on shooting for gold and upgrading to nvidia, 455.38, with kernel 5.4.0-54-generic, x86_64

I sort of am the guy who thinks if it ain’t broke, leave it the hell alone! Hahaha

A word of warning, read the article linked above very carefully if you have similar issues as I have experienced, ZFS is quirky and things can go bad quickly, I believe I was just lucky in this instance, get knowledgeable assistance.
lenscuba90

Just a bit of extra stuff-

When it was broken, sudo inxi -Fxz (showed above the following in
Graphics:
Device-1: NVIDIA TU106 [GeForce RTX 2070 Rev. A] vendor: ASUSTeK
driver: nvidia v: 435.21 bus ID: 01:00.0
Display: server: X.Org 1.20.8 driver: fbdev,nouveau FAILED: nvidia
unloaded: modesetting,vesa resolution: 1024x768~76Hz
OpenGL: renderer: llvmpipe (LLVM 10.0.0 256 bits) v: 3.3 Mesa 20.0.8
direct render: Yes

After it was fixed the new output was
Graphics:
Device-1: NVIDIA TU106 [GeForce RTX 2070 Rev. A] vendor: ASUSTeK
driver: nvidia v: 455.38 bus ID: 01:00.0
Display: server: X.Org 1.20.8 driver: nvidia
unloaded: fbdev,modesetting,nouveau,vesa
resolution: 1920x1080~60Hz, 1920x1080~60Hz
OpenGL: renderer: GeForce RTX 2070/PCIe/SSE2 v: 4.6.0 NVIDIA 455.38
direct render: Yes

Glad you got it working.
Updating the initramfs should automatically happen once you install a new kernel.
I don’t know why that didn’t happen. You didn’t tell me your initramfs decode error, might have lead the right way much earlier ;-p

It was an old error I had lived with for 8 months or so, always completing the boot and not being that much of an inconvenience to me, so I did not suspect it to be the problem.

I agree though, wish I had thought to bring it up, but I learnt a lot more from the actual long way around to the fix, and that’s a good thing.