Ubuntu 20.04.3 not starting if adding "Option “ColorSpace” “RGB”" in xorg.conf

If adding in xorg.conf the settings below

Option “ColorSpace” “RGB”
Option “ColorRange” “Full”

In next OS restart before user login screen the OS is halted and only start if removing the settings above.
LCD monitor is using VGA cable.
I had used the settings above because the documentation explain both settings are used in LCD monitors when using vga cable.
I remember using the settings above using a driver version before versions 470.

Really need the options above ?
Thanks for reply.

Could you post the full contents of the file? (ideally in a code block so the smart quotes don’t interfere)

Thanks for reply.
I have added the settings how are in nvidia documentation and when OS start the OS is halted before user login screen.
Ubuntu 20.04.3

XORG.CONF

nvidia-settings: X configuration file generated by nvidia-settings

nvidia-settings: version 470.86

nvidia-xconfig: X configuration file generated by nvidia-xconfig

nvidia-xconfig: version 470.86

Section “ServerLayout”
Identifier “Layout0”
Screen 0 “Screen0” 0 0
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”
Option “Xinerama” “0”
EndSection

Section “Files”
EndSection

Section “InputDevice”

# generated from default
Identifier     "Mouse0"
Driver         "mouse"
Option         "Protocol" "auto"
Option         "Device" "/dev/psaux"
Option         "Emulate3Buttons" "no"
Option         "ZAxisMapping" "4 5"

EndSection

Section “InputDevice”

# generated from default
Identifier     "Keyboard0"
Driver         "kbd"

EndSection

Section “Monitor”
Identifier “Monitor0”
VendorName “Unknown”
ModelName “LG Electronics E1641”
HorizSync 30.0 - 61.0
VertRefresh 56.0 - 75.0
Option “DPMS”
EndSection

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “NVIDIA GeForce GT 640”
EndSection

Section “Screen”
Identifier “Screen0”
Device “Device0”
Monitor “Monitor0”
DefaultDepth 24
Option “Coolbits” “8”
Option “Stereo” “0”
Option “nvidiaXineramaInfoOrder” “CRT-0”
Option “metamodes” “1366x768_60 +0+0 {ForceCompositionPipeline=On}”
Option “SLI” “Off”
Option “MultiGPU” “Off”
Option “BaseMosaic” “off”
Option “ColorSpace” “RGB”
Option “ColorRange” “Full”
SubSection “Display”
Depth 24
EndSubSection
EndSection

It doesn’t address the specific issue, but as a workaround you don’t need to set these options as they’re the defaults.

Thanks for reply.
I had used the same settings in driver previous version and not problems;
Trying with current version the OS not start.
Thus I had posted here if perhaps is a bug.

might very well be a bug since the settings are correct. Please run nvidia-bug-report.sh as root with your settings in place and attach the resulting nvidia-bug-report.log.gz file to your post.

Processing: nvidia-bug-report.log.gz…
Thanks very much for your reply.

Seems something went wrong, the attachment is still stuck in the virus scanner. Please try attaching it again.