Ubuntu 20.04 blocked after upgrading nvidia drivers

I was normally using an Nvidia GPU GTX 1650 on my computer with Ubuntu Desktop 20.04 LTS. After some updates (nvidia driver 510 and I think also ubuntu 20.04.3), the GPU stopped working and the pc couldn’t start.

I tried several times removing the nvidia drivers and installing them again (510, 470, 460), but the command $nvidia-smi never started working again.

Here some info:

~$ uname -r

~$ cat /etc/os-release

VERSION=“20.04.3 LTS (Focal Fossa)”
PRETTY_NAME=“Ubuntu 20.04.3 LTS”
PRIVACY_POLICY_URL=“Data privacy | Ubuntu

Here you can find the nvidia bug report:
nvidia-bug-report.log.gz (300.7 KB)

Thank you.

NVRM: GPU 0000:01:00.0: RmInitAdapter failed! (0x26:0x56:1253)

Might be broken.
The GPU fails to initialize, please check for properly connected power connectors, reseat card in its slot, check in another system for a general hardware failure.

I tested the GPU on a Windows computer and it works.
Moreover, I’m facing the same issue (RmInitAdapter failed) with another computer and another GPU. Everything works on Windows, but fails with Ubuntu. Any idea?

Thank you

There’s a similar issue
so I’m suspecting a runtime pm issue with recent nvidia driver versions. Please also post the output of
grep 10de /lib/udev/rules.d/* /etc/udev/rules.d/*

Seems this has been an issue before
that specific issue was then fixed in 470.86 but likely re-introduced now.

The output of

$ grep 10de /lib/udev/rules.d/* /etc/udev/rules.d/*


/lib/udev/rules.d/71-nvidia.rules:SUBSYSTEM=="pci", ATTRS{vendor}=="0x10de", DRIVERS=="nvidia", TAG+="seat", TAG+="master-of-seat"
/lib/udev/rules.d/71-nvidia.rules:ACTION=="bind", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x03[0-9]*", TEST=="power/control", ATTR{power/control}="auto"
/lib/udev/rules.d/71-nvidia.rules:ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x040300", TEST=="power/control", ATTR{power/control}="auto"
/lib/udev/rules.d/71-nvidia.rules:ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c0330", TEST=="power/control", ATTR{power/control}="auto"
/lib/udev/rules.d/71-nvidia.rules:ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c8000", TEST=="power/control", ATTR{power/control}="auto"

Please try to remove that file and run
sudo update-initramfs -u
afterwards. Then reboot and check if the gpu works.

This didn’t solve the issue. However I solved the issue by installing an old driver, by following this: *Bug* 470.42.01-1 dGPU can not be initialized - #13 by Kanguru007

These are the commands I entered:

#remove the current NVIDIA driver

sudo apt remove nvidia*
sudo reboot now

#disable the noveau driver

sudo echo "blacklist nouveau" >  /etc/modprobe.d/blacklist-nvidia-nouveau.conf
sudo echo "options nouveau modeset=0" >> /etc/modprobe.d/blacklist-nvidia-nouveau.conf
sudo update-initramfs -u
sudo reboot now

#install NVIDIA 460.84 driver
#downloaded from https://www.nvidia.com/Download/Find.aspx?lang=en-us

chmod +x NVIDIA-Linux-x86_64-460.84.run
sudo ./NVIDIA-Linux-x86_64-460.84.run
sudo reboot now

In the end, my configuration was:
Ubuntu: 20.04.2 LTS
Kernel: 5.13.0-30-generic
Nvidia driver: 460.84

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.