Ubuntu 20.04 Lenovo P71 second display stay black

Hi all,

i have installed the ubuntu 20.04 lts 64Bit OS and i can’t get the external monitor running.
I also tested all available drivers and the prime profile is switched to “performance mode”.
The monitor is working well on Windows 10.
I attached the bug report to hope that someone can told me why it stays black.

My laptop:
Lenovo P71
Nvidia Quattro M620
64Gb Ram

nvidia-bug-report.log.gz (136.2 KB)

Please uninstall bbswitch.

I have installed a fresh new version of the Ubuntu OS right now.
It has the same problem.
This is my first Linux OS. Please if you need some more details, then could you give me also the way how i can get these informations for you?

Thanks in advace
Sebastian

nvidia-bug-report.log.gz (380.4 KB)

The nvidia gpu is turned on now and the external connectors available but no monitors detected. How did you connect the monitor, are you using any converters?

The Monitor is plugged in into a docking station.
I also have plugged it into the laptop directly.

The attached file includes the report without the docking station. In this case the hdmi was plugged in the laptop directly.

nvidia-bug-reportWithoutDock.log.gz (399.3 KB)

No sign of any monitor. Did you already try using a different cable and switching to the correct input in the monitor’s menu?

I tried:

  • different hdmi cable (Docking station and directly connected to the laptop)
  • Display Port cable
  • a mini-dp adapter for hmdi and another one for DP

everytime the same result. The Monitor stays black. I can’t understand why the cable should be a problem, because the same hardware configuration is working with windows 10 very well.
The Source switch when i plugged in the device to the correct input. Yes, i have verified that they match.

How did you see that the gpu and external connectors are on?

Good to know this works in Windows so the hardware (monitor/cable/connector) can be taken out of the equation.
The driver lists all connectors and their state in the xorg log:

[    19.596] (--) NVIDIA(GPU-0): CRT-0: disconnected
[    19.596] (--) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
[    19.596] (--) NVIDIA(GPU-0): 
[    19.600] (--) NVIDIA(GPU-0): DFP-0: disconnected
[    19.600] (--) NVIDIA(GPU-0): DFP-0: Internal LVDS
[    19.600] (--) NVIDIA(GPU-0): DFP-0: 330.0 MHz maximum pixel clock
[    19.601] (--) NVIDIA(GPU-0): 
[    19.601] (--) NVIDIA(GPU-0): DFP-1: disconnected
[    19.601] (--) NVIDIA(GPU-0): DFP-1: Internal TMDS
[    19.601] (--) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
[    19.601] (--) NVIDIA(GPU-0): 
[    19.602] (--) NVIDIA(GPU-0): DFP-2: disconnected
[    19.602] (--) NVIDIA(GPU-0): DFP-2: Internal TMDS
[    19.602] (--) NVIDIA(GPU-0): DFP-2: 165.0 MHz maximum pixel clock
[    19.602] (--) NVIDIA(GPU-0): 
[    19.603] (--) NVIDIA(GPU-0): DFP-3: disconnected
[    19.603] (--) NVIDIA(GPU-0): DFP-3: Internal TMDS
[    19.603] (--) NVIDIA(GPU-0): DFP-3: 165.0 MHz maximum pixel clock
[    19.603] (--) NVIDIA(GPU-0): 
[    19.603] (--) NVIDIA(GPU-0): DFP-4: disconnected
[    19.603] (--) NVIDIA(GPU-0): DFP-4: Internal DisplayPort
[    19.603] (--) NVIDIA(GPU-0): DFP-4: 960.0 MHz maximum pixel clock
[    19.603] (--) NVIDIA(GPU-0): 
[    19.603] (--) NVIDIA(GPU-0): DFP-5: disconnected
[    19.603] (--) NVIDIA(GPU-0): DFP-5: Internal DisplayPort
[    19.603] (--) NVIDIA(GPU-0): DFP-5: 960.0 MHz maximum pixel clock
[    19.603] (--) NVIDIA(GPU-0): 
[    19.603] (--) NVIDIA(GPU-0): DFP-6: disconnected
[    19.603] (--) NVIDIA(GPU-0): DFP-6: Internal DisplayPort
[    19.603] (--) NVIDIA(GPU-0): DFP-6: 960.0 MHz maximum pixel clock
[    19.603] (--) NVIDIA(GPU-0): 

So I guess this is a driver bug. Please try:

I have added the kernel parameter as descripted. and i have downgraded the .driver to 470.

But it stays the same. External Monitor stays black. I also attached the bug report again.

nvidia-bug-report.log.gz (415.2 KB)

Problem:
The P71 has its gpu on an MXM card which has an on-board vbios prom but also a vbios image embedded into the system bios. The mxm prom contains an outdated minimal vbios but is preferred by the nvidia driver and also nouveau. Nouveau has the option to switch it.

Solution:

  1. with nouveau drivers: Set driver on Nouveau and add Kernel Paramater “nouveau.config=NvBios=ACPI”
  2. with Nvidia drivers: Set driver on Nvidia and do a Vbios Update.

Many Thanks
Sebastian

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.