Ubuntu 20.04 LTS xorg.conf does not work with nvidia

My PC: Core 2 Quad Q6600, XFX Geforce 8600GT 512MB VRAM, 8GB RAM, HD 400GB, Ubuntu 20.04 LTS.

Graphics Driver: NVIDIA-Linux-x86_64-340.108 (the latest for my graphics card)

The main crucial item of the whole configuration is the monitor used: LG model 22LG30R.

I am using the “component video” monitor input, and this is what is being used in ubuntu
settings, and is being recognized normally, but the maximum resolution available on ubuntu
is 1024x768.

The nvidia 340 driver was installed automatically during ubuntu installation.

The manual installation of the same driver was tested and the result was the same.

xorg.conf changed by me: (in folder /etc/X11/xorg.conf.d)

Section “ServerLayout”
Identifier “Layout0”
Screen “Screen0”
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”
Option “Xinerama” “0”

Section “Files”

Section “Module”
Load “dbe”
Load “extmod”
Load “type1”
Load “freetype”
Load “glx”

Section “InputDevice”
Identifier “Mouse0”
Driver “mouse”
Option “Protocol” “auto”
Option “Device” “/dev/psaux”
Option “Emulate3Buttons” “no”
Option “ZAxisMapping” “4 5”

Section “InputDevice”
Identifier “Keyboard0”
Driver “kbd”

Section “Monitor”
Identifier “Monitor0”
VendorName “LG”
ModelName “TV-0”
HorizSync 15.0 - 67.0
VertRefresh 59.0 - 60.0
Modeline “1280x1024_60” 108.000000 1280 1360 1496 1712 1024 1028 1032 1063 -HSync +VSync
Modeline “1680x1050_60” 148.250000 1680 1784 1968 2256 1050 1054 1058 1090 -HSync +VSync
Modeline “1920x1080_60” 148.500000 1920 2032 2240 2560 1080 1084 1088 1116 -HSync +VSync
Option “DPMS”
Option “PreferredMode” “1280x1024_60”

Section “Device”
Identifier “Device0”
Driver “nvidia”
BusID “PCI:1:0:0”
VendorName “NVIDIA Corporation”
BoardName “GeForce 8600 GT”
Option “UseEDIDFreqs” “false”
Option “NoEDIDModes” “true”
Option “ModeValidation” “TV-0: NoMaxPClkCheck, NoEdidMaxPClkCheck, AllowNonEdidModes”
Option “IgnoreEDID” “true”
Option “IgnoreEDIDChecksum” “TV-0”

Section “Screen”
Identifier “Screen0”
Device “Device0”
Monitor “Monitor0”
Option “HorizSync” “TV-0:15-67”
Option “VertSync” “TV-0:59-60”
DefaultDepth 24
Option “Stereo” “0”
Option “nvidiaXineramaInfoOrder” “TV-0”
Option “TwinView” “0”
Option “TwinViewXineramaInfoOrder” “TV-0”
Option “Metamodes” “1280x1024_60”
Option “SLI” “Off”
Option “MultiGPU” “Off”
Option “BaseMosaic” “off”
Option “AddARGBGLXVisuals” “True”
Option “TVStandard” “HD1080p”
Option “UseDisplayService” “TV”
Option “TVOutFormat” “COMPONENT”
Option “UseEDID” “False”
SubSection “Display”
Depth 24
Modes “1920x1080_60” “1680x1050_60” “1280x1024_60” “1024x768” “800x600” “640x480”
ViewPort 0 0
Visual “TrueColor”

Using general modeline generators, the modeline is generated with a pixel clock above that
accepted by the monitor.

The only generator that accepts pixel clock is umc (universal modeline creator).
But neither in ubuntu settings, in the monitor item, nor in nvidia-settings, the maximum
resolution is 1024x768.

I want to use the resolutions 1280x1024 and 1680x1050 and 1920x1080.

According to the monitor’s manual, these resolutions are possible using “component video”,
page 7:


Using Windows 7 and Windows 10 on the same PC with the same configuration,
and also using “component video”, on the same monitor, all resolutions are accepted:
640x480, 800x600, 1024x768, 1280x1024, 1680x1050, 1920x1080.

Ubuntu 20.04 LTS was tested, with standard xorg.conf (created by nvidia-xconfig), and
connected the PC to the monitor using HDMI, and all these resolutions work normally,
automatically recognized by the nvidia driver), 640x480 up to 1920x1080.

I didn’t mention that before creating xorg.conf and also changing it, I didn’t have
xorg.conf in the system, and the problem was the same.

Another observation is that they do not work:
xrandr, does not let you create new video modes.

Ubuntu has been reinstalled 4 times (20.04 LTS) on this same PC, from scratch, with
full installation options, plus the option to download updates during installation.
I believe it is quite complete, with libs (.h) installed, gcc etc.

The output of inxi -G: indicates driver nvidia 340.108, video card Geforce 8600GT,
and Xorg 1.20.8.

But no resolution configurator recognizes more than 1024x768, neither in Ubuntu Monitors
config, nor in nvidia-settings.

Xorg log: (resumed)

[ 42.894] (WW) NVIDIA(0): No valid modes for “TV-0:1920x1080”; removing.

[ 42.894] (WW) NVIDIA(0): No valid modes for “TV-0:1680x1050”; removing.

[ 42.894] (WW) NVIDIA(0): No valid modes for “TV-0:1280x1024”; removing.

[ 42.895] (II) NVIDIA(0): Validated MetaModes:

[ 42.895] (II) NVIDIA(0): “TV-0:1024x768”

[ 42.895] (II) NVIDIA(0): “TV-0:800x600”

[ 42.895] (II) NVIDIA(0): “TV-0:640x480”

[ 42.895] (II) NVIDIA(0): Virtual screen size determined to be 1024 x 768

[ 42.896] (WW) NVIDIA(0): Unable to support custom viewPortOut 1024 x 576 +0 +96

[ 42.923] (==) NVIDIA(0): DPI set to (75, 75); computed from built-in default

[ 42.923] (**) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.

[ 42.923] (II) NVIDIA: Using 768.00 MB of virtual memory for indirect memory access.

[ 42.932] (II) NVIDIA(0): Setting mode “TV-0:1024x768”


I uninstalled nvidia driver and installed nouveau:

CTRL + ALT + F3 (F1 does not work, black screen flashing cursor)

sudo su

service gdm3 stop

CTRL + ALT + F3 (again)

apt-get autoremove --purge nvidia-*

apt-get install xserver-xorg-video-nouveau


Note: whenever I enter the terminal like this, start gdm3 does not work

Result: only 640x480 resolution, even using my xorg.conf and changing in
/etc/default/grub (GRUB_GFXMODE=1024x768), or even 1280x1024, he insists on 640x480

Conclusion: I went back to the nvidia driver, which was previously installed automatically
during ubuntu installation, now I did the manual process, similar to the one shown above.

CTRL + ALT + F3 (F1 does not work, black screen flashing cursor)

sudo su

service gdm3 stop

CTRL + ALT + F3 (again)

apt-get remove --purge xserver-xorg-video-nouveau

chmod + x ./NVIDIA…340.run


New try:



Before entering the login screen, the screen is blinking with a green image, and after a few blinks, return to the prompt with a blinking cursor, having to press CTRL + ALT + F3, to go to the console.