Ubuntu 22.04 not starting correctly

Ubuntu on agx orin 64gb takes up to 5 attempt to produce the correct screen using jetpack 6
black screen with icons, then screen with backgroud picuture and no icons and repeats this between 3-6 time before producing correct screen.

Hello,

Thanks for visiting the developer forums! Your topic will be best served in the Jetson category.

I will move this post over for visibility.

Cheers,
Tom

DevKit/custom board?
Are you still able to login via serial console while it produces a black screen?

Hello DaveYYY
The black screen I mentioned has Icons displayed (mouse clicks do nothing)

I take it using serial console is connecting a mico usb from orin to laptop running minicom
I have tried this but not having any luck with minicom and devs ttyACM0-3
any chance of some help

Nothing we can do without any log.

Nothing I can do without getting minicom to work which I finally managed to do
by spelling dev not dav which I had i my command line.

Here is the capture file from minicom

minicom.txt (106.9 KB)
Cheerzs

Is this a custom board or NV devkit?

devkit agx orin 64

Please reflash it again and see if you can always reproduce this issue.

Reflash using sdk manager or is there ota way?
Reflash will loose the work over the last 2 days!

It is just for debug purpose. Backup your important data first.

If you don’t want, then maybe you can try to share how to reproduce this error.

I’ll reflash using sdk manager as I have only set up a couple of containers. I would rather have jetpack6 working properly first.
Will be back after reflash

Also try to check if the error is caused by the containers.

reflashed system with error in container section retried and loaded everything ok.
Great difficulty installing firefox so I can reply to the messages.
Can’t login to nvidia on agx orin keep getting gateway timout
I have a screen with icons loaded first time. I have not tried to change background image to see if I can emulate previous situation.
Will gradually reinstall items/software/containers and reboot after evert install.
p.s. lots of ubuntu errors

Can no longer login to any nvidia accounts on agx orin using firefox . times out
Machine without firefox is useless.
Firefox on xavier nx is fine as this is where I am sending this message.
Tomorrow is anorther Day

Firefox is not by default available on JetPack 6 because Ubuntu switch to the snap-based Firefox package on 22.04, and it cannot be used because we don’t install snap in our rootfs.

Please focus on your current issue now.

1 Like

Seem’s I was having problems with my internet connection yesterday . I am now
able to login to Nvidia forums etc. OK
I use firefox as it is the only browser to sync between arm machines and also microsoft and ios. It’s installed and working ok.

Loaded jetson-inference container, updated system, rebooted ok
loaded jetson-stats rebooted ok
installed cups rebooted ok

  1. noticed in jetson-inference container keyboard response is slow ! (was the same before)(dusty_nv is aware of ot this idiosyncrasy)
    Currently downloading model for text-generation-webui
    Will let you know how I get on.

Query
Just used sdk manager to upgrade. Finish with errors in
Cuda-X AI
TensorRT

SDKM_logs_JetPack_6.0_(rev._1)_Linux_for_Jetson_AGX_Orin_modules_2024-05-15_16-09-09.zip (512.0 KB)

Jtop tells me
Libraries
CUDA 12.2.140
cnDNN 8.9.4.25
TensorRT 10.0.1.6

Any clues.
In getting sdkm log onto ths computer my usb sticks are xfat yet another rabbit hole to fall into.!
Formatted as ntfs easier than trying to get ubuntu 22.04 to understand xfat

Some good news
Loaded dustynv/text-generation-webui container ok
using efficient large model_VILA-13b
seems to work ok.
System booting ok no more screen loading attempts
Look forward to your reply
cheers

Run

sudo apt update
sudo apt install nvidia-jetpack

on your device.

Thanks for reply :-
Looks like I have a broken system
Is their a fix i.e. sudo apt fix-broken ------ or do I have start from total re-install
Cheer in anticipation

sudo apt update
[sudo] password for paul:
Reading package lists… Done
E: Could not get lock /var/lib/apt/lists/lock. It is held by process 2522 (packagekitd)
N: Be aware that removing the lock file is not a solution and may break your system.
E: Unable to lock directory /var/lib/apt/lists/

sudo apt install nvidia-jetpack
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
nvidia-tensorrt-dev : Depends: python3-libnvinfer-dev (= 8.6.2.3-1+cuda12.2) but 10.0.1.6-1+cuda12.4 is to be installed
Depends: onnx-graphsurgeon (= 8.6.2.3-1+cuda12.2) but 10.0.1.6-1+cuda12.4 is to be installed
Depends: tensorrt (= 8.6.2.3-1+cuda12.2) but 10.0.1.6-1+cuda12.4 is to be installed
E: Unable to correct problems, you have held broken packages.