Ubuntu 22.04: Vsync bug, performance issues, nvidia-settings and Steam + Proton don't apply


using driver 515.65.01 on Ubuntu 22.04.1 LTS. GPU: Nvidia T600 from Lenovo.

A few issues:

1. I am affected by this bug:

Workaround: Turning both vsync and page flipping off in the Nvidia Control Panel via nvidia-settings helps and reduces the performance drop, but it’s not an optimal solution bc now videos, webbrowsers and even games have lots of tearing.

Which leads me to point 2: Using nvidia-settings to force vsync, anti aliasing or anistropic filtering for games played via Steam in general, Steam Proton doesn’t work. This goes for games running via DXVK and for games using OpenGL via PROTON_USE_WINED3D=1 %command% launch command. Games installed natively seem to respect whatever I set in nvidia-settings, like Xonotic for example, which was installed via the Ubuntu Software Center. Using the .deb Steam installer right now btw, but I also tried with the Snap version of Steam, same issue as described above.

I tried generally forcing vsync, AA and AF for everything, but I also tried creating application profiles for Steam and each game, to no avail.

In addition, point 3: I can see lots of tearing in games using Proton and DXVK. If I disable DXVK and use PROTON_USE_WINED3D=1 %command% instead, screen tearing goes away and the games run more stable in terms of avg fps.

Questions: How do I fix the above and does the issue of Steam Proton ignoring nvidia-settings have anything to do with this maybe? → NVIDIA application profiles are not exposed through pressure-vessel (#73) · Issues · steamrt / steam-runtime-tools · GitLab

Usually I would force a full composition pipeline in order to fix some of the issues described above, but I feel like that introduces additional lag when gaming and recording + on Ubuntu 22.04. In addition, I am unable to create and save an xorg / x11 file in etc due to the recent security changes of my distro, which means that I can’t save any of these changes after a reboot.

Last but not least, almost forgot to mention, Wayland isn’t affected by point 1 and 3, it’s a tearfree and relatively smooth experience, but screen and window recording via Pipewire and OBS is super laggy (low framerate), which is why I can’t use Wayland on Nvidia rn as I often upload videos to Youtube and the likes.

None of these issues occure on my AMD and Intel powered computers, and it would be nice if we could sort this out on my Nvidia machine.

Ty & Cheers

This also sounds highly linked to the issue I have when I use xorg session - UseNvKmsCompositionPipeline set to false mandatory to fix hitches/stutters/unresponsiveness

It is possible that they are linked/related to each other.