Ubuntu 23.10 (windows dual boot--secure ) - RTX- 3070 mobile Nvidia 535 or 545, NVIDIA driver will not load

Since upgrading to 23.10, I have been unable to get nvidia drivers to load correctly on dual GPU laptop(Asus Tuf dash F15).

I have removed (purged - sudo apt autoremove nvidia* --purge
) the different versions of the drivers I have tried to install, used the ubuntu front-end to install drivers, then also ubuntu-drivers. All of them have the same issue currently, with the following error displayed when running nvidia-smi
(NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.)

I have attached the bug report log, as well as some system information if that is helpful. I uploaded them in zip as the gz would never upload?

systemInfo.zip (1.1 KB)

nvidia-bug-report.zip (159.3 KB)

Well taking the following steps seems to have worked for me still using secure boot.

sudo mokutil --import /var/lib/shim-signed/mok/MOK.der

You’ll be prompted for your password, and you’ll be taken to the MOK screen upon reboot

  • enter the screen of Perform MOK management, please select Enroll MOK > Continue > Yes
  • Enter the password at the screen of Enroll the key(s)?

I have the same exact issue except that key is already enrolled and this didn’t begin until this morning after upgrading some packages. Now no matter what I install, 525, 535, 535 open, everything produces the same NVIDIA-SMI error and the driver never loads. I’m not sure what’s wrong.

I did see that update today, but did not yet install as I was wondering if I would run into the same issue. Now below is a list of everything I had tried in my troubleshooting process. Not sure if any of this will help. One other quick note, I had already register my key in the past as well, but re-enrolling is what fixed the initial issue for me.

List of step taken from forum and other sites.


* sudo apt-get purge 'nvidia*'  or sudo apt autoremove nvidia* --purge
* sudo add-apt-repository ppa:damentz/liquorix
* sudo add-apt-repository ppa:graphics-drivers/ppa
* sudo apt update
* sudo ubuntu-drivers devices
** driver   : nvidia-driver-545 - third-party non-free recommended
* sudo ubuntu-drivers autoinstall or install through GUI (make sure it is the version you want to install 3rd party non-free
* sudo apt install --reinstall linux-headers-$(uname -r)
* sudo mokutil --import /var/lib/shim-signed/mok/MOK.der
** Set the password in the configure secure boot stage, and remember your password

reboot system


Operation steps in MOK screen

    If you enter the screen of Perform MOK management, please select Enroll MOK > Continue > Yes
    Enter the password at the screen of Enroll the key(s)?
    Select OK to reboot

After rebooting, nvidia-smi command worked.
1 Like

It was installing version 545 that fixed it. Thank you! I had tried 535, 535 open, 525, nothing was working. I never even had an option to install 545 until, I assume, after adding those repos. I had tried reinstalling the headers, removing and reenrolling the MOK, you name it. Nothing worked. I’m assuming something in the updated packages is incompatible with drivers below version 545 then because I skipped the last three steps just to see if the new version was all I needed and it worked.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.