ubuntu 9.04 2.6.28.14 server version help

My 64 bit system could not find proper Nvidia driver, and in the Administration -> Hardware Driver, no matter which driver I chose (180.xxx, 173), i would not be able to activate the graphics card. <img src=‘http://hqnveipbwb20/public/style_emoticons/<#EMO_DIR#>/crying.gif’ class=‘bbc_emoticon’ alt=’:’(’ />

Then i tried to manually install Nvidia driver, stopped Xs, sudo sh LONG_NVIDIA_NAME_DRIVER.run, it told me it could not find kernel source tree info (kernel source or kernel devel) RPM. :fear:

Help please! :ph34r:

If you want to use CUDA you should install the CUDA driver instead of the default driver. I use Ubuntu 9.04 desktop version and I do not found any problem with the installation.

thanks tluisrs :yes:

Today i reinstalled the whole ubuntu 9.04 again. And problem solved.

My steps are:

  1. install the 2.6.28.11 server;
  2. without install gnome, “sudo apt-get install build-essential linux-headers-uname -r
  3. wget the cuda 2.3 driver for ubuntu 9.04
  4. at this moment, since no gnome installed, no X-server is on, “sudo sh NVIDIA_LONG_NAME_64_BIT_DRIVER.run”
  5. It asked me if I would like to install 32 bit compatible OPEN GL library, i said yes
  6. Installed Nvidia driver sucessfully
  7. install gnome
  8. reboot
  9. in gnome, run “sudo nvidia-xconfig”

After done with above, go to System -> Preferences -> Display, it would say something about some feature is not there, it asks whether you want to use alternative driver from your graphics card. Choose “YES”, then you can see the Nvidia X driver Utilities Panel

ONE MORE THING: after changing all the display settings, you would like to save that xorg.config, but the system would tell you it could not remove/create xorg.config.backup. What I did was, clicked on the preview settings, and copied the whole thing, manually changed xorg.config by editor.

And now you can reboot, and you will see the display setting is still there!

Also the CUDA SDK samples worked on my system!
(Added some lib such as libglut3, libxi and libmu to make the “make” under SDK run)

Yahoooooo! :lol: