Ubuntu doesn't detect my second HDMI display

Hello. For almost 2 weeks now, I have been trying to install nvidia drivers in Ubuntu 18.04. I need them for deep learning always. Didn’t face any difficulties while installing them in Ubuntu 16.06 (I used it previously). However, both in 18.04 and 20.04 I couldn’t install it. There were always some issues or the other.

I am using an Asus TUF505DV laptop, and I I am not able to connect to an external monitor using HDMI. With the default drivers, the external monitor is detected but there are many glitches in the screen. With the Nvidia drivers, the monitor is not at all detected. In windows it’s working fine.

Also, when I try to open Nvidia control panel, it doesn’t show a thing. The window opens and then minimizes with nothing inside them.

I have tried a lot of things till now but I couldn’t even start using the external monitor display, neither could I configure the Nvidia drivers for deep learning. I followed every steps that are there in the nvidia blogs. But no help. Nothing is working.

Hi,
I’m not sure if it helps you or anybody else, but came across same/similiar problem.
I installed ubuntu 20.04 and then installed nvidia drivers.(It asked after installation to dissable secure boot), though after restarting laptop, I though it was done automaticaly. However, it was not.
Solution for me was to manually dissable Secure boot in BIOS.

Hi all,

I am having the very same problem with ubuntu 20.04 and 18.04, and it has been haunting me for months now. Issue dynamics:

For quite some time the second monitor HDMI connection went smooth, but then suddenly the monitor was not detected. The HDMI entry was not even present in xrandr output. I was running Xubuntu 18.04. After trying everything, I decided to install ubuntu 20.04 on another partition. This solved the problem for some weeks (on both partitions), but suddenly the monitor is again undected, (on both partitions).

I literally tried everything, from several Nvidia drivers to shift between lighdm to gdm3, to press Fn F5, to all possible combinations of boot-screen on-cable connection, to disable secure boot in BIOS. No success.

Technical specs:

Laptop: Acer Aspire-E5-573G
Kernel: 5.4.0-40-generic x86_64
Graphic card: NVIDIA GK208BM [GeForce 920M]
Current driver: nvidia 440.100

Here is my nvidia bug report as suggested before in the thread. Please help me out of this nightmare :Dnvidia-bug-report.log (283.5 KB)

I’m on ubuntu 18.04 and had the same issue a few months ago, then I switched to lightdm and it worked. Now after a BIOS update (Asus ROG string G531GT) it stopped working again and I can’t fix it. I also have Ubuntu Studio 20.04 installed and it also doesn’t work.
Here is my log file: nvidia-bug-report.log.gz (155.8 KB)

I’m having this problem. I just took a standard Ubuntu software update and now the OS can’t find my external screen and also identifies the laptop screen as “unknown display.” I restarted into the grub screen as suggested but the system is booting into the latest kernel 5.4.x already.nvidia-bug-report.log.gz (172.5 KB)

Disabling Secure Boot worked indeed. Looks like a ubuntu kernel issue, not nvidia.

My secure boot is already disabled. I just checked.

I have these messages from dmesg:

[ 62.103319] NVRM: The NVIDIA GPU 0000:01:00.0 (PCI ID: 10de:1f10)
NVRM: installed in this system is not supported by the
NVRM: NVIDIA 390.138 driver release.
NVRM: Please see ‘Appendix A - Supported NVIDIA GPU Products’
NVRM: in this release’s README, available on the operating system
NVRM: specific graphics driver download page at www.nvidia.com.
[ 62.103365] nvidia: probe of 0000:01:00.0 failed with error -1
[ 62.103379] NVRM: The NVIDIA probe routine failed for 1 device(s).
[ 62.103380] NVRM: None of the NVIDIA graphics adapters were initialized!
[ 62.254518] nvidia-nvlink: Unregistered the Nvlink Core, major device number 234
[ 62.310485] nvidia-nvlink: Nvlink Core is being initialized, major device number 234
[ 62.310856] nvidia 0000:01:00.0: vgaarb: changed VGA decodes: olddecodes=none,decodes=none:owns=none
[ 62.310879] NVRM: The NVIDIA GPU 0000:01:00.0 (PCI ID: 10de:1f10)
NVRM: installed in this system is not supported by the
NVRM: NVIDIA 390.138 driver release.
NVRM: Please see ‘Appendix A - Supported NVIDIA GPU Products’
NVRM: in this release’s README, available on the operating system
NVRM: specific graphics driver download page at www.nvidia.com.
[ 62.310927] nvidia: probe of 0000:01:00.0 failed with error -1
[ 62.310941] NVRM: The NVIDIA probe routine failed for 1 device(s).
[ 62.310941] NVRM: None of the NVIDIA graphics adapters were initialized!

Secure Boot is already disabled. I just checked.

I have uploaded the log from dmesg. There is a lot of messages about NVIDIA here repeated. I am just adding the last set of messages.nvidia-dmesg.txt (1.5 KB)

I’m not sure how this is supposed a kernel issue. this all started after the latest apt software update.

I have explored further and did the following:

sudo ubuntu-drivers autoinstall

this installed the latest nvidia driver 440
then I rebooted but the desktop would not start
i hard rebooted and went into recovery mode
then I ran the following to remove all the nvidia drivers completely

sudo apt remove --purge ‘^nvidia-.*’

after that, i was able to boot normally.
i repeated all the steps to be sure it was reproducible.

seems like the latest nvidia drivers don’t want to play nice. there are lots of reports of this happening when I search for it but I haven’t found a satisfactory solution. any assistance would be appreciated. I’m on ubuntu 18.04

I run ubuntu 20.04 on a laptop with GTX1660 it won’t detect my 2nd HDMI monitor no matter what.

I’ve been reading through this forums and I’ve tried several suggestions but nothing worked.

I’ve attached the log hopefully you can help.

nvidia-bug-report.log.gz (124.8 KB)

Hi I have a similar problem in my DELL G3 with GEFORE GTX Card . I use ubuntu 18.04 nvidia-bug-report.log.gz (458.9 KB)

I got the same issue since this morning, yesterday everything was working fine.

I’m running Ubuntu 20. How do I generate that report.log file to upload it? thank you.

cat /var/crash/nvidia-dkms-450.0.crash
────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────
ProblemType: Package
DKMSKernelVersion: 5.4.0-45-generic
Date: Wed Sep 2 08:14:09 2020
Package: nvidia-dkms-450 450.66-0ubuntu0.20.04.1
PackageVersion: 450.66-0ubuntu0.20.04.1
SourcePackage: nvidia-graphics-drivers-450
Title: nvidia-dkms-450 450.66-0ubuntu0.20.04.1: nvidia kernel module failed to build


and also

udo apt install nvidia-driver-450
Reading package lists… Done
Building dependency tree
Reading state information… Done
nvidia-driver-450 is already the newest version (450.66-0ubuntu0.20.04.1).
The following packages were automatically installed and are no longer required:
libnvidia-common-418-server libnvidia-common-435 libnvidia-common-440-server
Use ‘sudo apt autoremove’ to remove them.
0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up nvidia-dkms-450 (450.66-0ubuntu0.20.04.1) …
update-initramfs: deferring update (trigger activated)
INFO:Enable nvidia
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/dell_latitude
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/put_your_quirks_here
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/lenovo_thinkpad
Removing old nvidia-450.66 DKMS files…


Deleting module version: 450.66
completely from the DKMS tree.

Done.
Loading new nvidia-450.66 DKMS files…
Building for 5.4.0-45-generic
Building for architecture x86_64
Building initial module for 5.4.0-45-generic
ERROR: Cannot create report: [Errno 17] File exists: ‘/var/crash/nvidia-kernel-source-450.0.crash’
Error! Bad return status for module build on kernel: 5.4.0-45-generic (x86_64)
Consult /var/lib/dkms/nvidia/450.66/build/make.log for more information.
dpkg: error processing package nvidia-dkms-450 (–configure):
installed nvidia-dkms-450 package post-installation script subprocess returned error exit status 10
dpkg: dependency problems prevent configuration of nvidia-driver-450:
nvidia-driver-450 depends on nvidia-dkms-450 (<= 450.66-1); however:
Package nvidia-dkms-450 is not configured yet.
nvidia-driver-450 depends on nvidia-dkms-450 (>= 450.66); however:
Package nvidia-dkms-450 is not configured yet.

dpkg: error processing package nvidia-driver-450 (–configure):
dependency problems - leaving unconfigured
No apport report written because the error message indicates it’s a follow-up error from a previous failure.
Processing triggers for initramfs-tools (0.136ubuntu6.2) …
update-initramfs: Generating /boot/initrd.img-5.4.0-45-generic
Errors were encountered while processing:#######…]
nvidia-dkms-450
nvidia-driver-450#################################…]
E: Sub-process /usr/bin/dpkg returned an error code (1)

Thanks. This helped and fixed all my dual monitor issues. Thx

I also have this problem. I had everything working until very recently, and I suspect the software update caused all of these issues.
I have two monitors connected to a 1650 Super. The one connected with DP works, but the one with HDMI does not. It doesn’t even show up in xrandr. I have tried lightDM as well, no change (are there specific settings I need?) . I have tried reinstalling nvidia drivers using the instructions above (purge first and then install) and it didn’t work. I have checked that my secure boot is also disabled.
Here is my nvidia bug report
nvidia-bug-report.log (824.4 KB)

This fixed my issue:

  1. Download the latest driver from Nvidia:
    https://www.nvidia.com/Download/index.aspx
  2. Follow these instructions:
    https://askubuntu.com/questions/149206/how-to-install-nvidia-run

same problem on ubuntu 20.04

both monitors were working fine on nouveau drivers, after installing 390 and rebooting only one monitor works

bug report:
nvidia-bug-report.log.gz (146.1 KB)

Did you create the log while a monitor was connected?
Please try running

xrandr --setprovideroutputsource modesetting NVIDIA-0; xrandr --auto

Please post the output of
xrandr --listproviders

Reinstalled ubuntu, here’s a new bug report: nvidia-bug-report.log.gz (145.8 KB)

and the output for the commands you said:

(sorry for the delay to reply btw)