Ubuntu Dual-Boot RTX 3060 Screen Resolution & Can't Detect Monitor


I’ve been following this thread: hxxps://forums.developer.nvidia[.]com/t/nvidia-driver-is-not-loaded-ubuntu-18-10/70495/314 With no luck.

Summary: I’m on a dual-boot Ubuntu 22.04 with an RTX 3060 GPU, AMD CPU. I stream on OBS. Everything was fine until recently I attempted recording on OBS and my camera source crashed. Updated NVIDIA Driver on the Windows partition. Then updated straight from NVIDIA website in Ubuntu. Rebooted to one screen at resolution of 1024 and the other isn’t detected at all.

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected primary 1024x768+0+0 0mm x 0mm
   1024x768      76.00* 

First, following the linked forum, I purged nvidia, re-installed from Software & Updates, disabled Wayland, ensured nvidia wasn’t blacklisted, and rebooted. Screen was toxic-waste yellow.

Found online that disableing Wayland likely caused that so I set Wayland back to true. Rebooted and all appeared well.

In OBS, ffmpeg was still installed but I wasn’t able to set the encoder to ‘NVENC’. It appeared that it didn’t exist. I followed hxxps://docs.nvidia[.]com/video-technologies/video-codec-sdk/ffmpeg-with-nvidia-gpu/ (won’t let me post multiple links) with no improvement.

This morning I attempted to purge and re-install nvidia driver. Updates and Software recommended nvidia-driver-525-open so installed that. Rebooted and back to original problem with resolution and undetected monitor.

Following the other forum post, I did sudo apt purge cuda* nvidia then followed these steps: hxxps://developer.nvidia[.]com/cuda-downloads?target_os=Linux&target_arch=x86_64&Distribution=Ubuntu&target_version=22.04&target_type=deb_local
BUT DID NOT INSTALL CUDA and instead ran apt install cuda-toolkit-12-1

Reboot = no change.

Following the forum some more I made sure it was booting from the same kernel (?).

/var/lib/dkms/nvidia$ ls
525.89.02  kernel-5.19.0-35-generic-x86_64

and in nvidia-bug-report.log

Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.19.0-35-generic 

At this point IDK what else to do, I’m already pretty lost as is about this stuff. Please let me know how I can fix this issue :( and thanks for your time.

P.S. Some other outputs which might help:

$dkms status
nvidia/525.89.02, 5.19.0-35-generic, x86_64: installed
virtualbox/6.1.38, 5.19.0-32-generic, x86_64: installed
virtualbox/6.1.38, 5.19.0-35-generic, x86_64: installed
No devices were found
$prime-select query

$ sudo prime-select nvidia
Error: no integrated GPU detected.

In /etc/gdm3/custom.conf:


nvidia-bug-report.log (1.8 MB)

1 Like

Wrong driver. Please use Software & Updates to switch to the non “-open” driver version.

Okay, first I tried using the Software and Updates GUI to install nvidia-driver-525. Immediately got a popup window w/ just an ‘X’ and no text.

So then I tried sudo apt-get remove --purge ubuntu-driver-525-open and got this in response: nvidia-driver-525-open is not installed. Then I tried sudo ubuntu-drivers install nvidia-driver-525 and got All the available drivers are already installed.

Update: I tried it one more time from the Software and Updates GUI and this time it worked! THANK YOU!!

For future reference, choose the ‘recommended’ driver from Software and Updates but NOT the open version…

Also, do I need to do any clean up?

I don’t think so.

Same error here, with 3060ti, i used this tutorial and works for me:
SecureBoot - Debian Wiki.


Having disk space issues. /usr/local/cuda-12.1 is 5.4G with /cuda-12.1/targets being 4.8G of that. During this fiasco about a month ago, I remember part of the solution was to NOT install CUDA. Doing some searching, I haven’t found any answer as to whether I can safely delete this directory, or at least the targets directory.

Nothing in the directory itself has been modified in over a month according to Disk Usage Analyzer. Do you happen to know if I can get rid of it?