Ubuntu freezes at login with the gtx860m's official drivers installed

I apologize ahead of time as I do not have any log files available-I wiped the install-it’s pretty useless to me without these drivers functioning properly.

But I did an install received the error message saying the preinstall did not work, installed anyway. Went to reboot and after typing in my password ubuntu freezes. I waited about two minutes and figured it wasn’t going to function.

I reverted to the old drivers and ubuntu would load again.

I’m using an ASUS G750JM laptop. I’ve searched all over the internet for anything about this and found nothing.

If and or when I install ubuntu again I will get the log files and post them here if any are available.
[This file was removed because it was flagged as potentially malicious] (121 KB)

Well if you got to the login screen then at least the video driver was loaded and working.

It’s hard to say what happened after that.

It could be something in nvidia-settings since I think that runs at login. Or it could be something not related to nvidia at all.

It’s somehow related to the graphics driver because later that day I wiped the system, reinstalled a fresh 14.04 and the driver as well and the same thing happened. It just freezes after I hit enter to login. Shortly I will install again and see if I can find any log files, because I really want this resolved, I’ll post them up here.

Try logging into a different type of session too, like GNOME or whatever else is listed. It could be a Unity problem and that might be a piece to the puzzle.

Just reinstalled ubuntu, having same problem, got the log file, which was a pain everytime I tried to do startx verbose 6 command my screen would go completely blank and I would have to power off so I couldn’t get that.
[This file was removed because it was flagged as potentially malicious] (121 KB)

I don’t have any other sessions available

Why do you try to install the driver yourself and do not simply stick to this?

https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia

There are no restricted drivers available for me.

Yeah, in a nutshell Ubuntu doesn’t support your hardware.

It looks like the open-source nouveau module is being loaded in addition to the nvidia driver, but fails because nouveau doesn’t support the 860m yet… or at least the version installed doesn’t.

The nouveau driver is typically uninstalled / blacklisted when you install the nvidia driver through the Ubuntu restricted drivers app; but as you say, Ubuntu is not updated with the latest nvidia drivers that support your GPU.

If you really want to get it working, you might want to investigate how to blacklist nouveau to at least get you to the point where you’re only loading the official nvidia driver.

Can you get to a virtual console at least (Ctrl-Alt-F1 at the login screen)?

Yep

Well I followed the instructions here:http://www.linuxers.org/howto/how-remove-nouveau-drivers-ubuntu and still having the same problem. I’ve been looking all over for the script/log file and can’t find it. I thought it was /var/lib/nvidia but I don’t have permission to view that folder.

I’m not very experienced with Linux so please go easy on me:)

I think you’re better off installing from a PPA so let’s try to get you to that point. (Though if you’re up for it maybe it’s easier to just start with a fresh install of Ubuntu.)

  • Undo the step 1 in the link above (the changes to blacklist.conf).
  • Drop to a virtual console (Ctrl-Alt-F1) and bring down the display manager:
    sudo service lightdm stop
  • Bring down the display server:
    sudo killall X
  • Uninstall the nvidia driver; this depends on the command you ran to install it initially but just take that command and add an --uninstall at the end. So maybe something like this:
    sudo ./NVIDIA-Linux-x86-64-340.32.run --uninstall

Install nvidia driver from xorg-edgers PPA:

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-340 nvidia-settings

Reboot:

sudo shutdown -r now

If that works and things are running then we’ll go back and disable the xorg-edgers PPA and work on any necessary display configuration tweaks.

Well, it’s up and running as far as I can tell. I’m going to test the graphics and make sure in a little bit. However the system froze about five minutes in and I had to go to shell $sudo stop lightdm then $sudo start lightdm

And it’s back up running, could have been a coincidence; not sure. I’ll let you know if it’s really working shortly.

It just froze again, I’m not doing anything at all to make it freeze :(

Can you post /var/log/kern.log from a session where you experienced the freeze?

Can you post /var/log/Xorg.0.log and /etc/X11/xorg.conf also?

Yeah
kern.log (281 KB)
Xorg.0.log (34.2 KB)

Xorg.conf ( i thought the rest of them would be too big to copy and paste here):

Section “ServerLayout”
Identifier “layout”
Screen 0 “nvidia”
Inactive “intel”
EndSection

Section “Device”
Identifier “intel”
Driver “modesetting”
BusID “PCI:0@0:2:0”
EndSection

Section “Screen”
Identifier “intel”
Device “intel”
EndSection

Section “Device”
Identifier “nvidia”
Driver “nvidia”
BusID “PCI:1@0:0:0”
Option “ConstrainCursor” “off”
EndSection

Section “Screen”
Identifier “nvidia”
Device “nvidia”
Option “AllowEmptyInitialConfiguration” “on”
EndSection

Those are on a working session (I don’t know if that matters.) It appears that the graphics are working other than that. Ubuntu created a huge report to send in when I came back from the crashes.