Ubuntu MATE 20.04 with RTX 3070 on Ryzen 5900 - black screen after boot

Absolutely the same problem and remains after trying the fix. Asus Rog Strix G17 G713QM 2021 (RTX 3060, Ryzen 5800H)

1 Like

A new G713QM user with Ubuntu 21.04 here. Found a fix for the shutdown issue! I stumbled into hid-asus-rog repository here asus-linux / hid-asus-rog · GitLab and saw the latest commit message “Filter random XF86PowerOff events” from 2 months ago. That looked promising. However, here ASUS NoteBook Linux it said that if you have kernel 5.11+, you don’t need the dkms module. I decided to try anyway. So I installed the deb and rebooted and… nothing.

Then I checked the repository tags and saw that the installed package was older than the latest commit so I tried the manual installation (ASUS NoteBook Linux). Rebooted again and what do you know, no more keyboard issue!

1 Like

I’ve just had a very similar problem on an Acer Nitro 5 (5800h - rtx 3070), but on ubuntu 20.04 (no MATE). Just updating the kernel solved it for me.
I used the oem kernel Kernel/OEMKernel - Ubuntu Wiki which is currently at 5.10, and I installed it with sudo apt install linux-oem-20.04b

1 Like

Not a question, but a report of successful driver installation.

Computer: ASUS Rog Strix G17 G713QM-HX121.
GPU: NVIDIA RTX3060 laptop + Radeon RX Vega 8.
CPU: Ryzen7 5800H.
System: Ubuntu 20.04, minimal installation, no sudo apt upgrade done.

I followed the solution provided in the pinned post with this answer as an additional guidance.

Differences from the accepted solution:

  • I used linux kernel version 5.11.0;
  • There was no need to apply the patch, so I skipped the step 3.

Comments:

  • Although a newer nvidia driver was available (465), I installed 460, since that was the driver that was available at the time the solution was posted.
  • In this linux kernel version (5.11.0), as it was mentioned by Kaczor, the laptop’s keyboard is not functional and the computer can’t turn itself off.
  • As of now, the green_sardine firmware is still needed to be installed, as mentioned in the solution.

These are the issues that I’m currently OK with, since I can use an external keyboard and switch the computer off by pressing the corresponding key. Maybe someday I’ll have the guts to update the kernel or install an asus-specific drivers to address these problems. But for now, I’m just happy with my nvidia gpu working correctly.

Thanks to generix and predte4a and Kaczor.

Hi, ollipuu,
Could you, please, elaborate what kernel version do you have and what exactly have you done to fix the shutdown problem?

I have tried several 5.11+ kernels and the keyboard doesn’t work with any of them. I also tried to install the hid-asus-rog driver, despite the fact that it claims to be unnecessary for 5.11+, and got no results.

Hi, I may have celebrated too early. First the issue started to appear again randomly and now it seems it’s broken again. I don’t know if some update broke it. But basically I had clean Ubuntu 21.04 and then cloned the hid-asus-rog repository and build and installed the module manually.

Hi, I am also facing the same issue with asus rog stirx scar 15 ryzen 7 5800H and RTX 3060 laptop. I am currently using ubuntu 18.04 with 5.10.15 kernel running. I tried with other kernel like 5.8.3, 5.10.14, 5.11.0 but still getting the same ubuntu power off action with any of the key presses. Is it a issue with laptop should I get my laptop changed? I had also tried the hid-asus-rog with no luck. It is really annoying I am stuck on my work. Please help ASAP.

Hi Kaczor,

I have

Asus ROG STRIX SCAR G533QS-HT210 RTX3080 16GB AMD Ryzen9 5900HS

I have installed Ubuntu 18.04 Kernel Version 5.11.1, My GPU is working Fine , but somehow my wifi is not working.

Have you tried any other higher stable version of ubuntu kernel ?

Hello, sorry for the late response,

First of all - I’m not well experienced with Linux 😅

Currently I installed kernel v 11.16 and this is last version which is able to build without strange errors. I installed it using using ‘mainline’. But… because of some reasons it is not possible to install nVidia drivers and cuda under this kernel. Because of that I’m forced to install these drivers under another kernel version on which it is possible to install all nVidia drivers and after update kernel to 11.16.
Let me know please if you’ll find solution

Best regards
PS.

I’m using Ubuntu 20.4 - I don’t know if 18.04 can be issue…

I had a problem with the wifi and solved it by disabling the ipv6 (kernel version 5.14.10).

If I use the 5.11.0-37-generic kernel version I have this problem me too.

Installing Ubuntu Mate 21.04 seems to make nvidia availble. nvidia-smi runs ok. The only problem is with the wireless adapter and the bluetooth one.

libnvidia-cfg1-470/hirsute-updates,hirsute-security,now 470.63.01-0ubuntu0.21.04.2 amd64 [installed,auto-removable]
libnvidia-common-470/hirsute-updates,hirsute-updates,hirsute-security,hirsute-security,now 470.63.01-0ubuntu0.21.04.2 all [installed,auto-removable]
libnvidia-compute-470/hirsute-updates,hirsute-security,now 470.63.01-0ubuntu0.21.04.2 amd64 [installed,automatic]
libnvidia-decode-470/hirsute-updates,hirsute-security,now 470.63.01-0ubuntu0.21.04.2 amd64 [installed,auto-removable]
libnvidia-encode-470/hirsute-updates,hirsute-security,now 470.63.01-0ubuntu0.21.04.2 amd64 [installed,auto-removable]
libnvidia-extra-470/hirsute-updates,hirsute-security,now 470.63.01-0ubuntu0.21.04.2 amd64 [installed,auto-removable]
libnvidia-fbc1-470/hirsute-updates,hirsute-security,now 470.63.01-0ubuntu0.21.04.2 amd64 [installed,auto-removable]
libnvidia-gl-470/hirsute-updates,hirsute-security,now 470.63.01-0ubuntu0.21.04.2 amd64 [installed,auto-removable]
libnvidia-ifr1-470/hirsute-updates,hirsute-security,now 470.63.01-0ubuntu0.21.04.2 amd64 [installed,auto-removable]
linux-modules-nvidia-470-5.11.0-37-generic/hirsute-updates,hirsute-security,now 5.11.0-37.41 amd64 [installed,automatic]
linux-modules-nvidia-470-generic/hirsute-updates,hirsute-security,now 5.11.0-37.41 amd64 [installed]
linux-objects-nvidia-470-5.11.0-37-generic/hirsute-updates,hirsute-security,now 5.11.0-37.41 amd64 [installed,automatic]
linux-signatures-nvidia-5.11.0-37-generic/hirsute-updates,hirsute-security,now 5.11.0-37.41 amd64 [installed,automatic]
nvidia-compute-utils-470/hirsute-updates,hirsute-security,now 470.63.01-0ubuntu0.21.04.2 amd64 [installed,auto-removable]
nvidia-kernel-common-470/hirsute-updates,hirsute-security,now 470.63.01-0ubuntu0.21.04.2 amd64 [installed,automatic]
nvidia-prime/hirsute,hirsute,now 0.8.16.1 all [installed,automatic]
nvidia-settings/hirsute-updates,now 470.57.01-0ubuntu0.21.04.2 amd64 [installed,auto-removable]
nvidia-utils-470/hirsute-updates,hirsute-security,now 470.63.01-0ubuntu0.21.04.2 amd64 [installed,auto-removable]
xserver-xorg-video-nvidia-470/hirsute-updates,hirsute-security,now 470.63.01-0ubuntu0.21.04.2 amd64 [installed,auto-removable]

Is there any tutorial on how to build and install glibc latest version from sources?

Hi. I have

Ubuntu 18.04.6 5.4.0-87-generic with updated kernel to 5.10.14. Installed NVidia Driver 460
Laptop Asus ROG STRIX RTX3070 Ryzen 5900HX. Nvidia driver does not start.

Any help will be much appreciated.
Thanks.

nvidia-bug-report.log.gz (119.0 KB)

@kgboyko
There is no sign of the kernel modules being built. There is no sign of the driver trying to load.
So I guess the module build failed.
Do you have the kernel-headers for your kernel installed? linux-image-$(uname-r) would be the name of the package.
What does dkms status say?

If the kernel headers are not installed, do install them. Then run sudo apt install --reinstall nvidia-driver-460.

Uninstalled NVidia driver. Once again installed all four kernel files. There were no error messages. Then I installed the NVidia 460 driver again.

$ dkms status
nvidia, 460.91.03: added

Checked the installation of installing the kernel headers.
$ uname -r
5.10.14-051014-generic

$ dpkg-query -s linux-headers-5.10.14-051014
Package: linux-headers-5.10.14-051014
Status: install ok installed
Priority: optional
Section: devel
Installed-Size: 72180
Maintainer: Ubuntu Kernel Team kernel-team@lists.ubuntu.com
Architecture: all
Multi-Arch: foreign
Source: linux
Version: 5.10.14-051014.202102071532
Depends: coreutils
Description: Header files related to Linux kernel version 5.10.14
This package provides kernel header files for version 5.10.14, for sites
that want the latest kernel headers. Please read
/usr/share/doc/linux-headers-5.10.14-051014/debian.README.gz for details

$ dpkg-query -s linux-headers-5.10.14-051014-generic
Package: linux-headers-5.10.14-051014-generic
Status: install ok installed
Priority: optional
Section: devel
Installed-Size: 14322
Maintainer: Ubuntu Kernel Team kernel-team@lists.ubuntu.com
Architecture: amd64
Source: linux
Version: 5.10.14-051014.202102071532
Provides: linux-headers, linux-headers-3.0
Depends: linux-headers-5.10.14-051014, libc6 (>= 2.14), libelf1 (>= 0.142), libssl1.1 (>= 1.1.0)
Description: Linux kernel headers for version 5.10.14 on 64 bit x86 SMP
This package provides kernel header files for version 5.10.14 on
64 bit x86 SMP.
.
This is for sites that want the latest kernel headers. Please read
/usr/share/doc/linux-headers-5.10.14-051014/debian.README.gz for details.

I tried to install on Ubuntu-20.04.3 LTS. If you specify the option to install a proprietary driver immediately, it will not be installed. If you do not specify this option during installation, and then install it directly from the upgrade & update, then it is installed perfectly.

nvidia-bug-report.log.gz (128.6 KB)

It should say installed.

The module compiling fails:

scripts/Makefile.modpost:117: recipe for target ‘__modpost’ failed
make[2]: *** [__modpost] Error 2
Makefile:1709: recipe for target ‘modules’ failed
make[1]: *** [modules] Error 2
make[1]: Leaving directory ‘/usr/src/linux-headers-5.10.14-051014-generic’
Makefile:80: recipe for target ‘modules’ failed
make: *** [modules] Error 2

This most likely is caused by a compiler mismatch between the version used to build your kernel (10.2) and the default system compiler (7.5).

Systems compiler:

gcc version 7.5.0 (Ubuntu 7.5.0-3ubuntu1~18.04)

Kernel compiled with:

*** /proc/version
*** ls: -r–r–r-- 1 root root 0 2021-10-11 16:37:27.743050858 +0300 /proc/version
Linux version 5.10.14-051014-generic (kernel@kathleen) (gcc (Ubuntu 10.2.0-13ubuntu1) 10.2.0, GNU ld (GNU Binutils for Ubuntu) 2.35.1) #202102071532 SMP Sun Feb 7 15:52:46 UTC 2021

As your laptop is a brand new model and Ubuntu 18 is quite old, I’d advise for installing at least Ubuntu 20. Also might be good to use kernel 5.14 and nvidia driver 470.

Thanks a lot for the help and clarification! I will then use the new version of Ubuntu.