Ubuntu not selecting nvidia driver, still hows intel mesa

I am using ubuntu 22.04LTS, and NVIDIA drivers sucks. it automatically changes or updates the drivers and then have compatibility issues.
I have NVIDIA GeForce GTX 1650 , and driver I have installed is NVIDIA-SMI 535.113.01. I have tried ‘sudo prime-select nvidia’ it runs fine but cant select nvidia driver still uses same intel mesa.
Due to this my default mouse cursor lags so annoyingly randomly.
Could someone please help me with the default settings and how can I fix this issue?
below are the details

~❯ inxi -G
Device-1: Intel TigerLake-H GT1 [UHD Graphics] driver: i915 v: kernel
Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] driver: nvidia
v: 535.113.01
Device-3: Quanta HD User Facing type: USB driver: uvcvideo
Display: wayland server: X.Org v: with: Xwayland v: 22.1.1
compositor: gnome-shell v: 42.9 driver: X: loaded: vesa
unloaded: fbdev,modesetting gpu: i915 resolution: 1920x1080~144Hz
OpenGL: renderer: Mesa Intel UHD Graphics (TGL GT1)
v: 4.6 Mesa 23.0.4-0ubuntu1~22.04.1

@tomcarry1992 does this pertain to Omniverse at all? if it does, GTX isn’t supported on the platform (only RTX cards are supported). if not, you could try the GeForce forum.

here is the technical requirements for OV - Technical Requirements — Omniverse Platform latest documentation

I am sorry, I dint understand. My only problem is why nvidia drivers are not stable with ubuntu LTS versions. this mismatch is causing my default touchpad mouse lags so much.
How do I fix it ?
I have tried removing nvidia completely and then reinstalled using autoinstall. its using the latest driver , why its not selecting NVIDIA as openGL renderer.
Is their any way to make nvidia as a default graphics card?
I also tried booting it up with xorg, ubuntu-gnome, wayland. nothing helps.

i am implying this thread may be posted in the wrong forum if your issues isn’t related to Omniverse. however, after a quick search, i was able to get a few results; here is one:

unfortunately i will not be able to assist further. you can wait for the mods to respond, though.

i think your question will be suited for the Linux forum:

I am also attaching the bugreport. nomodeset was already removed. I dont use graphics much. but its just the default touchpad cursor lags randomly which irritates me alot.

I have tried all the forum questions related to this topic. Nothing helps. If you find something in the bug report.
nvidia-bug-report.log.gz (316.2 KB)


You have a hybrid graphics notebook meaning the intel igpu is primary gpu. With nomodeset you’re disabling the intel driver so nothing will really work. Now with ‘nomodeset’ removed, you’re running a wayland session instead of Xorg, the secondary nvidia gpu can only be used by using render offload through Xwayland.
If you’re still having issues with the touchpad in this state, it’s rather not graphics related.
If you want the nvidia gpu alway being used as default (not recommended due to high power consumption), switch to an Xorg session and use prime-select nvidia. Rather check how render offlaod works: https://http.download.nvidia.com/XFree86/Linux-x86_64/545.29.02/README/primerenderoffload.html

1 Like

Hey, thanks for your reply.
The issue was not related to the nvidia graphics, The issue was -
I had windows as primary OS, and ubuntu was in dual boot. My default touchpad was lagging in windows as well. There were drivers in windows, bios, chipset and touchpad drivers, I tried updating them that dint work either. Then acer support suggested to reset it to the default settings. I did the same and now the lag has gone.

  • I am using wayland with default intel graphics card and it working fine now.


Update ** - This is not a permanent fix, I am still getting the random lags in touchpad in Ubuntu. God knows how to fix it.