Ubuntu not using GPU, though nvidia-drivers are installed and nvidia-smi cannot find devices

nvidia-bug-report.log.gz (157.2 KB)
I’m running Ubuntu 22.04 next to Windows on a Dell XPS 15 7950. I have tried a few nvidia drivers and now have the recommended nvidia-driver-525-open. However, my pc still seems to run on llvmpipe (LLVM 15.0.6, 256 bits), according to the ‘About’ window in Ubuntu.

I want to run the nvidia drivers because of GPU performance and because I want to use external monitors (which stopped working this morning on the default 22.04 install).

Any help is greatly appreciated! Please let me know if I need to attach more logs or can do anything else to provide more info

Please remove nomodeset kernel parameter.
Wrong driver. Please use Software & Updates to switch to the non “-open” driver version.

Thanks! Removing nomodeset fixed it for me, didn’t even have to change the driver.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.