Ubuntu session is not starting on XPS 9510


I’m using Ubuntu 21.10 on my XPS Dell 9510.

I have tried to install nvidia drivers, v470 and v495, with integrated drivers (apt) and linux package (on nvidia.com). I have the same result: a back screen when I start ubuntu. GUI session is not starting.

I have collected a log file with the nvidia-bug-report tool. Result is attached.

Could you help me please ?

nvidia-bug-report.log.gz (320.8 KB)


Kernels used:

  • 5.13.0
  • 5.15.8

First: you should use the distro package, not the .run file. It’s better integrated and the upgrade path is no hassle. Always use the --uninstall switch of the .run file, before installing any other nvidia driver package.

  • Please delete: /etc/X11/xorg.conf
  • Install/Re-install the distro package with apt.
  • Run sudo prime-select nvidia
  • reboot.

If that does not help, run sudo prime-select on-demand (maybe even in recovery, or over ssh), reboot and create a new bug-report.

Perfect !

Thanks you very much.

So, that’s not in Wayland, though. Is your wayland session working yet?

That screenshot right there can only be taken from an Xorg session, because nvidia-settings (both the GUI and the terminal command) do not work in Wayland, they require the NV-CONTROL X extension (usually provided by libxnvctrl but it may vary based on your distro).

Anyway it even says you’re in an X11 session.

So can you check and see if your issue is actually fixed and you can start a Wayland session?

You obviously won’t be able to check with nvidia-settings, because it doesn’t work in Wayland, but you can run echo $XDG_SESSION_TYPE from a terminal and it should say wayland if you’re in Wayland.

You’re right. I’m no x11.
I will keep x11. All my apps works better on x11 (nvidia-settings also).