Ubunu 18.04 (Elementary OS) and NVIDIA 435.17

I installed the staging driver from this ppa: https://launchpad.net/~mamarley/+archive/ubuntu/staging

I can see the nvidia-drm and other modules have been loaded but it doesn’t seem to work.

xrand --listproviders only shows one provider and glxinfo give med a “X Error of failed request: BadValue (integer parameter out of range for operation)”

Will attache debug-info…

nvidia-bug-report.log.gz (598 KB)

It doesn’t look like the driver was installed correctly:

[  1844.136] (II) LoadModule: "nvidia"
[  1844.137] (WW) Warning, couldn't open module nvidia
[  1844.137] (EE) Failed to load module "nvidia" (module does not exist, 0)

But in addition to that, there are a lot of errors for a variety of devices in your system log. It might be a good idea to run memtest86+ on this system.

Ops I attached a bug-report from when I tried compiling the module myself (which failed). I’ll attach the one from when I installed it using the ppa instead.

Sorry for the inconvenience…

I decided to do a reinstall from the ppa and just like that it started working :D

Attaching my bugreport, does it still look like I should run memtest86 or?
nvidia-bug-report.log.gz (1.09 MB)

I don’t see anything obviously bad in your log, other than a crash in some application called “wingpanel”.

I’d still recommend running memtest86+ at some point, mostly just because it’s a good idea to run it every once in a while just in case.

Great! Thanks for all the help :)

This feature has been so much longed by me and I’m loving using it :D

GREAT WORK!!!