Unable re-flash AGX Xavier P2872 emmc from host USB

Hi all,
I’m having strange issues with USB communication failures starting with tegrarcm_v2. I had been working from:

https://docs.nvidia.com/jetson/l4t/#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide/quick_start.html#

to install JetPack 4.5.1 from an Ubuntu 20.04.2 Focal host (that’s all I have available).

I can at least confirm that the USB port is behaving as if the Xavier is in Recovery Mode. (I’ve read a very long thread that I can no longer locate that indicated this does not guarantee that in fact the device is actually in recovery mode):

Bus 002 Device 002: ID 05e3:0620 Genesys Logic, Inc. USB3.1 Hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 006: ID 0955:7019 NVIDIA Corp.
Bus 001 Device 004: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 003: ID 148f:7601 Ralink Technology, Corp. MT7601U Wireless Adapter
Bus 001 Device 002: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

However, flash.sh fails since tegrarcm_v2 --uid can’t establish communication with the Xavier (reports: “USB communication failed.Check if device is in recovery”).

There was an older post a year or two ago about tlp package being the issue but nevertheless I ‘blacklisted’ the vendor:device description without any luck. I’ve also tried every possible combination of setting it back in RECOVERY mode (Power-on… RECOVER/Reset, RECOVER=>Power-on). Removing all cables sans the power supply and USB-C cable, etc.).

Note that there is also an internal NVME.2 disk in addition to the 32GB emmc. (I can’t see how this would adversely affect the USB comm (??)).

Any help/advise how to better go about this I would really appreciate it-- spent all day trying to resolve this one.

thanks ,
-t

hello tmorris2,

this should be platform with eMMC, could you please remove the nvme to flash the image.
thanks

Hi JerryChange,
I took it out and still have the same error with tegrarcm_v2 --uid

“USB communication failed. Check if device is in recovery”

lsusb returns the same info.

You (or anyone) know what the Xavier is sending to initiate the connection?
Any reliable sniffer to pole activity over the installed USB hubs?

-t

are you flashing the board through USB hubs? sometime is power issue with the hub (or, a laptop) to loss connection,
could you please setup the board connection with your host x86 machine directly.
btw, are you using virtual machine?

No, I mean the USB ‘hub devices’. It’s plugged directly into the actual host.
I don’t use a VM.

hello ted.morris,

for clarification,
is it a typo for AGX Xavier P2872, it should be P2972, right?
you may also check Jetson FAQ | NVIDIA Developer for the part number of Jetson Modules and SoCs.
thanks

Yes, my bad –
945-82972-0000-000
S/N: 0423818098510

Hi JerryChang,

I got it to reflash without problems using a different host. (a Dell Latitude 7480 laptop running Mint 19.3 , – e.g., Ubuntu 18.04). To note, I was trying to do this with an ODROID N2+ running Ubuntu 20.04.

thanks,
-ted

hello tmorris2,

thanks for feedback,
according to NVIDIA SDK Manager | NVIDIA Developer, it’s only support Ubuntu or CentOS on x86_64 system
thanks

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.