Unable streaming by Argus for 640x480 resolution

I tried video streaming using nvargus for the resolution 640480 stream but I am not getting the video stream.I read somewhere that there is support for 640480 stream… Can we change something in Dispatcher.cpp from the Argus camera app to get something.

What’s your BSP?

cat /etc/nv_tegra_release

Please refer the highlighted part in the picture.

Could you update to r32.6.1

Hi @ShaneCCC we did that but it looks like argus is not able to capture camera data. for 640480 stream…can you confirm whether argus 640480 is supported by libargus? because it works for 1920*1080 camera stream.

Please replace the libnvscf.so from below link.

Hi @ShaneCCC even after applying the patch file I am not getting the 640*480 stream through libargus.

Getting the below error message.
nvbuf_utils: dmabuf_fd -1 mapped entry NOT found
nvbuf_utils: Can not get HW buffer from FD… Exiting…
ERROR: from element /GstPipeline:pipeline0/GstNvArgusCameraSrc:nvarguscamerasrc0: CANCELLED
Additional debug info:
Argus Error Status

Hi @ShaneCCC any update on this thread… I am still not able to stream 640*480 using libargus…The patch file you provided doesnt work…I have a doubt on the sdk manager version that is being used for flashing. Will that affect the functionality of libargus.


Did you confirm v4l2-ctl able capture successfully?

Yes v4l2 works fine argus is not working for 640 stream

Could you try infinite mode.


Hi @ShaneCCC yes we have tried infinite timeout mode as well but not getting the Argus out

Looks like try every things I know, Current we don’t have any reference design to verify it.
Maybe using any others sensor mode.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.