Unable to access Orin

Will reflash Orin erase my data?

Yes, it will. Just wonder, did you ever reflash your board before?

I haven’t tried reflash yet

Good day Wayne, that was just a copy paste of what the terminal print at the moment. I managed to find out how to print logs using UART terminal. I append the whole Xorg.0.log as a .txt. Reading myself the logs I found some worrying lines

[    21.388] (WW) Warning, couldn't open module nvidia                          
[    21.388] (EE) Failed to load module "nvidia" (module does not exist, 0)  

And also near the end of the log a no device detected error was launch

[    21.391] (II) Module fbdevhw: vendor="X.Org Foundation"                     
[    21.392]    compiled for 1.20.13, module version = 0.0.2                    
[    21.392]    ABI class: X.Org Video Driver, version 24.1  
[    21.392] (EE) open /dev/fb0: No such file or directory                      
[    21.392] (EE) No devices detected.                                          
[    21.392] (EE)                                                               
Fatal server error:                                                             
[    21.392] (EE) no screens found(EE)      

At the time of running the log no Display was connected to the Orin

Best regards!!!

XORG_Orin.txt (9.5 KB)

Hi @Farideh

For your case, please share me the result of “lsmod” too.

Error is from:

    21.387] (II) LoadModule: "nvidia"                                          
[    21.388] (WW) Warning, couldn't open module nvidia                          
[    21.388] (EE) Failed to load module "nvidia" (module does not exist, 0)     
[    21.388] (==) Matched modesetting as autoconfigured driver 0

Hello Wayne
Running lsmod on the command prompt returns an empty list

Module          Size    Used by

I am unaware if i must run an additional parameter to show the modules


What is your uname -r result and your ls -a /lib/modules?

Hi Wayne

Running uname -r i got the folllowing printed


Meanwhile running ls -a /lib/modules returns

.  ..  5.10.65-tegra

Best regards!!

The dist upgrade might have broken something. I am curious what the output of this command is:
dpkg -l | egrep -i '(libnv|nvidia)'

Also, what is the output of:
find /lib/modules/$(uname -r) -iname '*.ko*'

Good day

Running both commands on the terminal it outputs

orin@orin-desktop:~$ dpkg -l | egrep -i '(libnv|nvidia)'                        
dpkg: error: need an action option                                              
Type dpkg --help for help about installing and deinstalling packages [*];       
Use 'apt' or 'aptitude' for user-friendly package management;                   
Type dpkg -Dhelp for a list of dpkg debug flag values;                          
Type dpkg --force-help for a list of forcing options;                           
Type dpkg-deb --help for help about manipulating *.deb files;                   
Options marked [*] produce a lot of output - pipe it through 'less' or 'more' ! 

orin@orin-desktop:~$ find /lib/modules/$(uname -r) -iname '*.ko'

Best regards

This shows something is seriously is wrong:

Do you get an an error from just “dpkg -l”? It should list all installed packages. The egrep was to filter for the most common packages from NVIDIA.

Can you manually do this:
cd /lib/modules/$(uname -r)

If you can, what shows up from that location using this command:
find . -type f

Running dpkg -l returns

| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)

Alonsides a 1000+ list of modules

Meanwhile runnning find - type f after the cd command returns

orin@orin-desktop:~$ cd /lib/modules/$(uname -r)
orin@orin-desktop:/lib/modules/5.10.65-tegra$ find . -type f

Best regards!!

So dpkg works, that is the expected output of “dpkg -l” (to list a lot of packages).

It seems though that your module directory is missing. There should be a lot more content there than that one file. The module you are missing which is most notable is the NVIDIA GPU driver, but you’ll have some serious problems beyond just this.

Have you ever tried to install a new kernel or module? Whatever has happened you lost all of your modules (which are dynamically loadable drivers).

good day
To the moment i have not tried to install any new kernel or module. As additional infromation that might be relevant is that I installed some nvidia-driver-3** (I dont remeber exactly the driver)

Can you please tell how to reinstall modules or kernel?

Best regards

Was that driver downloaded from a web site? It sounds like you tried to install a non-Jetson NVIDIA driver. This could have badly broken things. I hate to ask, but is there anything on this you can’t afford to lose? If not, then I’ll suggest just flashing it. If you have something you need to save, then you could first clone, flash again from scratch, and try to restore just those parts of the clone which you’ve customized or needed to save.

You have to be careful about installing any boot or GPU software onto a Jetson which is intended for a PC. The GPU is an integrated GPU (iGPU) and not the PCIe-based discrete GPU (dGPU). Boot content is getting closer to “standardized” due to UEFI, but it isn’t there yet, and so any GPU or boot software is typically installed only via SDK Manager. If not, then you might ask first here on forums about such software. Missing all of the kernel modules is not a “smoking gun” that this is what happened, but it is likely the cause since you’ve never manually installed a kernel.

Good day!
The driver downloaded was a nvidia driver installed from terminal as the one installed previously was obsolete for the use of CUDA on the orin following this guide CUDA Installation Guide for Linux

best regards

That’s for a desktop PC. Video cards which are PCIe (dGPU). Won’t work with the iGPU. CUDA needs to be installed from the same L4T release (L4T is what gets flashed, JetPack/SDKM is the front end flash software, and you can see the release with “head -n 1 /etc/nv_tegra_release”) which was flashed to the Jetson. You probably need to reflash (I don’t know if the dGPU driver can be backed out and the iGPU driver installed).

Thanks a lot for the information. Do you have a link to a nvida tutorial to do such reflash?

JetPack and L4T releases are tied together. You can find them through either of these URLs:

Documents for that release are on the particular page. Basically, for an Orin, the host PC should be either Ubuntu 18.04 or 20.04 (older releases, which Orins cannot use, would use 18.04).

The gist is to install the SDK Manager software on the host PC, and then run the sdkmanager itself as a regular user (do not use sudo, but it will ask for the admin password when needed). Be sure to log in to the developer portal rather than the partners portal (partners would tell you there are no downloads available for the account). The Jetson needs to be put into recovery mode, and connected via the correct USB-C. The recovery mode Jetson will become a custom USB device which the driver package (the L4T flash software) understands.

Do beware that you need plenty of extra disk space. Each time it will create an image the size of the rootfs partition, plus a “sparse” version of this. Thus, it needs a lot of disk space.

Thanks a lot for the information!!
there is only one inconvenience and it is that sadly when connecting the Orin to a Usb-c it is not found by the external computer
Do you have any information of how to fix this?