Unable to Attach/Launch with Tegra Graphics Debugger

I am using NVIDIA Shield for game development and I am unable to attach Tegra Graphics Debugger 1.3 to any of my processes.

I took my chances with the rooting method.
Because I couldn’t find any information from NVIDIA on rooting the device, I followed this tutorial:

https://www.youtube.com/watch?v=_8O-oXYzB8g

The device seemed to be rooted but it wasn’t enough to stop TGD from complaining -
I had to download “adbd insecure” application that would solve the error saying “adbd cannot run as root in production builds”.

Once that was done TGD seemed to be working, I succesfully installed the debugger and the global interposer with the help of these two buttons,
but once I launched my application it appeared grayed out on the process list - I couldn’t possibly attach the debugger.
Launching the APK directly from the debugger didn’t really help either - once the app started rendering, TGD didn’t even notice and remained focused on the “Launching APK…” window,
leaving me with no other possibility than to cancel the process of launching.

So I tried the non-rooting method, but in vain.
I added these:

include $(CLEAR_VARS)
NDK_APP_SHORT_COMMANDS := true
LOCAL_MODULE := libTegra_gfx_debugger
LOCAL_SRC_FILES := profiler/libTegra_gfx_debugger.a
include $(PREBUILT_STATIC_LIBRARY)

include $(CLEAR_VARS)
NDK_APP_SHORT_COMMANDS := true
LOCAL_MODULE := Stripped_libNvPmApi
LOCAL_SRC_FILES := profiler/stripped/libNvPmApi.Core.so
include $(PREBUILT_SHARED_LIBRARY)

include $(CLEAR_VARS)
NDK_APP_SHORT_COMMANDS := true
LOCAL_MODULE := Stripped_libTegra_gfx_debugger
LOCAL_SRC_FILES := profiler/stripped/libTegra_gfx_debugger.so
include $(PREBUILT_SHARED_LIBRARY)
# end tgd libs

These files are sure to exist because I resolved some filename errors on the way.

Then, after several tries, I managed to successfully load both the libraries in java:
(Funnily enough, this is not necessary for the application to start successfully)

System.loadLibrary("Tegra_gfx_debugger");
System.loadLibrary("NvPmApi.Core");

Once the app was started from eclipse it still didn’t appear attachable on the TGD list. Launching it directly from TGD didn’t help either.
Tried to remove the interposer/debugger in TGD and just use the ones provided within the libraries, with no effect.

My Shield is running Android 4.4.2 so I used KitKat libraries.

Any idea what could be the problem?

Hi,
In case you have rooted your device, you can launch apk from connection dialog, seems your app need time to initialize, so you see the launching apk window, it will disappear when your app start to render real scenes.

hope helps