Unable to backup orin nano nvme img

I want to backup orin nano’s image,but the script doesn’t work.
The L4T version is 35.3.1,and the script I used is “tools/backup_restore/l4t_backup_restore.sh”.First I find some issues in the original script,not available for NVME.So I changed a few things: changed mmcblk0 in both the scripts “nvbackup_partitions.sh” and “nvrestore_partitions.sh” to nvme0n1.It can backup the image, but cannot restore it.
I have two orin nano modules(nano1 and nano2) and two identical nvmes(nvme1 and nvme 2).The size of the nvme is 128G.Here are my steps:

Step1,flash system into nano1 with nvme1.

sudo ./tools/kernel_flash/l4t_initrd_flash.sh --external-device nvme0n1p1 -c tools/kernel_flash/flash_l4t_external.xml -p "-c bootloader/t186ref/cfg/flash_t234_qspi.xml" --showlogs --network usb0 jetson-orin-nano-devkit external

It started normally, then I installed Jetson Runtime Components and Jetson SDK Components through SDK manager.It works fine.

Step2,backup nano1 image.

sudo ./tools/backup_restore/l4t_backup_restore.sh -b jetson-orin-nano-devkit 

The script is executed successfully, and the image is saved in “tools/backup_restore/images”.

Step3,restore the image to nano2 with nvme2.

sudo ./tools/backup_restore/l4t_backup_restore.sh -r jetson-orin-nano-devkit

It doesn’t work.

flash_3-7_0_20230706-093001.log (6.5 KB)

What should I do to fix this?

I made some other attempts.
I can restore the image to nano1 with nvme1 and nano2 with nvme1 through cmd:

sudo ./tools/backup_restore/l4t_backup_restore.sh -r jetson-orin-nano-devkit

I also can restore the image to nano2 with a 256GB nvme.


can you try something like flashing the system to an SD card on either device, attaching the SSD #2, booting into the system to see if it can be correctly detected?

Based on your reply, there may be some issue about your SSD that fails to flash.

I don’t have an SD card designed on my motherboard.If there is a problem with NVMe, why can it be flash by l4t_initrd_flash.sh?

I mean, it may be specific to your NVMe 2.
Like, just as what you tried, if the same image can be restored to different modules installed with different SSDes, then it’s clear that you have some problem with your NVMe 2.

I changed to a different NVMe, and the result is still the same.
Is there another way to backup and flash new devices?

Did you understand what I’m saying here?
Maybe these SSDes are not even working properly when attached other devices like your host PC.

You may also try if flashing a fresh BSP works, and if it also fails while some other SSD works, then the answer is clear.

I can use the script “./tools/kernel_flash/l4t_initrd_flash.sh” to flash in any nvme I used successfully.


so the situation is that you have two Orin Nano modules and multiple NVMe SSD, and you can flash every combination of them with initrd flash, but when it comes to restoring, some of them will fail, while others still work.

Is that right?

After testing, backups and restores between the same storage sizes will fail.If I backup from small storage sizes nvme,and restores to a large storage sizes,it will success.


thanks for the clarification.
Just to make sure that, will you always succeed when backing up and restoring using exactly the same drive?

Yes,backing up and restoring using exactly the same drive,it will success.


then maybe there’s very slight difference in the size of these SSD. Like, maybe the NAND flash chips on an SSD add up to 128GB, but for some reason, it’s labeled as only 120GB.
Can you help to check that?

Or tell us the product models of SSD that you think that are the same in size but you fail to backup/restore in between.

The 128G nvme model I tested is the HIKVISION PTS11.The 250G nvme model is WD Blue SN570.


so you mean that say you have SN570 #A and SN570 #B, images can’t be shared between these two, but will do it when using a larger drive?


thanks for the information.
Then can you try dump UART log when you fail to restore the image?
Also, I’m not sure if it makes any difference, but always format the SSD as ext4 before flashing/restoring.

The restoring log:
restore.txt (84.4 KB)

“format the SSD as ext4 before flashing/restoring” is correct.
Thank you very much.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.