Unable to build .cu File with VSE++ 08

Hello everyone!

System information:

Windows Vista Home, SP2

Toolkit 2.2

SDK 2.2.1

Driver 186.03

Visual C++ 2008 Express Edition

I am able to compile and run the example Files of CUDA. I have also completed all steps of the Getting Started Document and varified that the installition is correct. Now I am trying to make my own example. Therefore I add a new directory in examples named testFiles where I have the file test1.cu with the following simple code:

By now clicking on Start Debugging following error occurs:

What I am doing wrong?

Greets Alex

OK, the problem discribed above has been solved … but there is a new one, I have expanded the program a little bit

Error:

I am using the German version - the Error is “error LNK2019: unresolved external symbol”

I read some topics with the same error and added the extern “C” thing, but it won’t help.

Does noone have any advice for me? :( If i posted in the wrong forum, please let me know

Regards

:wave:

I have exactly the same problem. I added in Linker Additional Dependencies msvcrt.lib.

that helped on some errors. but 10 errors are also with my compilation script on.Same then on yours.

Regards

teraflop

:rolleyes:

the problem is at another point.

the cuda/bin

there are bin2c.exe fatbin.exe filehash.exe

they all refer to dlls

a wer.dll bcrypt.dll and ncrypt.dll

if this 3 dlls are x86 they will not run on an x64 CPU environement

so for example fatbin cannot make the link then correctly

regards

teraflop