Unable to change network security settings on my Drive AGX Orin

Hello,
I was recently trying to change the network-security settings of one of the wifi networks on my Drive AGX Orin and I have observed that this is the case for all the wifi networks available. How can I fix this issue?

Could you clarify whether you’re working with a Jetson device or a DRIVE AGX Orin platform? If it’s DRIVE, please provide the following info:

Software Version
DRIVE OS 6.0.8.1
DRIVE OS 6.0.6
DRIVE OS 6.0.5
DRIVE OS 6.0.4 (rev. 1)
DRIVE OS 6.0.4 SDK
other

Target Operating System
Linux
QNX
other

Hardware Platform
DRIVE AGX Orin Developer Kit (940-63710-0010-300)
DRIVE AGX Orin Developer Kit (940-63710-0010-200)
DRIVE AGX Orin Developer Kit (940-63710-0010-100)
DRIVE AGX Orin Developer Kit (940-63710-0010-D00)
DRIVE AGX Orin Developer Kit (940-63710-0010-C00)
DRIVE AGX Orin Developer Kit (not sure its number)
other

SDK Manager Version
1.9.3.10904
other

Host Machine Version
native Ubuntu Linux 20.04 Host installed with SDK Manager
native Ubuntu Linux 20.04 Host installed with DRIVE OS Docker Containers
native Ubuntu Linux 18.04 Host installed with DRIVE OS Docker Containers
other

Software Version-DRIVE OS 6.0.8.1
Operating System- Linux
Hardware-DRIVE AGX Orin Developer Kit (not sure its number)
SDK Manager Version- 1.93.10904
Host Machine Version-native Ubuntu Linux 20.04 Host installed with SDK Manager

Could you provide more details on how you enabled WiFi on your Drive AGX Orin? It would help if you could describe what specific changes you were attempting to make to the network-security settings and any error messages or logs you encountered.

I am trying to change the security setting of the network from WPA3 personal to WPA and WPA 2 personal.
There is no error message as such but when I apply the changes the whole settings window gets closed and there is no such change that actually gets applied.

How did you enable WiFi after flashing DRIVE OS 6.0.8.1? Was the WiFi functionality working correctly before you tried to change the security settings?

I did manually enable the WiFi by installing the drivers and the wifi networks which have the security settings correct by default were working properly.

Thanks for clarifying. To understand your current setup, could you let us know what specific steps you took after flashing DRIVE OS 6.0.8.1 to get WiFi running and see the list of “Visible Networks”?

So, after the flashing of DRIVE OS I have followed couple of steps from the internet and NVIDIA Forums in order install the drivers for network and network manager.

Could you share the specific steps?